[ viss02 @ 02.07.2017. 22:13 ] @
Klasa 192.168.0.0/24 je backbone area i u njoj ima nekoliko rutera. Jedan od tih rutera je ABR i na njemu je klasa 192.168.3.0/24 koja pripada nekoj drugoj area.

Problem je sto ostali ruteri ne dobijaju uopste tu rutu, znaci ne znaju gde se nalazi 192.168.3.0/24 niti ko je GW. U toj klasi postoje 2 rutera koji ucestvuju u OSPF-u. Njih ima u ruting tabeli drugih rutera ali samo za njihov IP, ne za celu klasu.
Znaci dst=192.168.3.22 gw=192.168.3.1

Config sa tog rutera:

/ip address
add address=192.168.0.10/24 interface="ether2 - xxx" network=192.168.0.0
add address=10.0.7.129/25 interface="bridge Klijenti" network=10.0.7.128
add address=192.168.2.1/26 interface="ether5 - Loco" network=192.168.2.0
add address=192.168.2.65/26 interface="ether4 - yyy" network=192.168.2.64
add address=192.168.3.1/24 interface="ether1 - zzz" network=192.168.3.0
add address=10.255.255.8 comment="OSPF Router ID" interface=bridge-ospf \
network=10.255.255.8

/routing ospf area
add area-id=0.0.0.3 name=K2
/routing ospf instance
set [ find default=yes ] redistribute-connected=as-type-1 router-id=\
10.255.255.8
/routing ospf interface
add interface="ether2 - xxx" network-type=ptmp priority=2
add interface="ether4 - yyy" network-type=ptmp
add interface="ether1 - zzz" network-type=ptmp
/routing ospf network
add area=backbone network=192.168.0.0/24
add area=K2 network=192.168.2.64/26
add area=K2 network=192.168.3.0/24


Ruter bi trebao da redistribuira sledece rute:
10.0.7.128/25 - ovo je ok
192.168.2.1/26 - ovo je ok
192.168.2.64/26 - nema je
192.168.3.0/24 - nema je

Evo koje rute ruteri iz backbone area dobijaju od tog rutera (neke rute su redistribuirane i dolaze sa drugih rutera koji su van backbone area):
[ dragansar @ 03.07.2017. 12:50 ] @
Procito sam par puta ali ne mogu sve da zamislim u glavi a nemam kad da crtam...jel mozes da nacrtas semu sa oznacenim ruterima, mrezama koje oglasavas i OSFP area-ma gdje je sta pa da vidimo onda detaljno?
[ viss02 @ 03.07.2017. 15:30 ] @
Vrlo je jednostavno, ali evo saljem dijagram :)
Ovo sto je obelezeno crvenom se ne redistribuira, zeleno da.

Primetio sam da kada se neka klasa u /routing ospf networks doda onda se ona vise ne redistribuira i ako je ukljuceno "redistribute connected routes" u ospf -> instances

Tako da sam recimo uradio
Code:
/routing ospf network
add area=K2 network=10.0.7.129/25

onda se 10.0.7.129/25 ne bi redistribuirala dalje.
[ dragansar @ 04.07.2017. 08:46 ] @
Ovde mi nije jasno zasto ti redistribuiras rute kroz OSPF? Ako ruteri MT2-MT3 i MT2-MT4 ucestvuju u OSPF procesu onda ces oglasiti mreze koje su izmedju direktno spojene.
I onda OSPF pokusava da oglasi i rute koji su konektovane i one koje si mu ti rekao, i vjerovatno ti tu napravi problem.
Jos mi nije jasno sto ti je izmedju MT2 i MT3 mreza 192.168.3.0/24 a ne P2P link tipa /30...isto i za 192.168.2.64/26
[ viss02 @ 04.07.2017. 17:37 ] @
Zato sto izmedju ta dva MT-a postoji neka ubiquiti oprema koja se koristi za taj ptp link i kojoj je gateway MT2.

onda je
.3.1/24 MT2
.3.2/24 ubiquiti ap
.3.3/24 ubiquiti client
.3.4/24 MT 3

Mogu da napravim neku klasu /30 pa da na njoj budu ta dva MT-a, a za ubnt opremu da pravim neke vlan-ove za managment ili nesto trece ali to je sve nepotrebno komplikovanje. Ovo je prilicno jednostavno a dovoljno pouzdano.

Citat:
I onda OSPF pokusava da oglasi i rute koji su konektovane i one koje si mu ti rekao, i vjerovatno ti tu napravi problem.


Izgleda da je tako i da tu ne mogu nista da uradim. Problem sam privremeno resio tako sto sam na MT1 dodao rutu 192.168.3.0/24 i ukljucio da redistribuira i staticke rute, sada imam pristup toj ubiquiti opremi ali nije mi to to. Inace to sto nemam pristup toj opremi to me i motivise da podesavam da svi ruteri znaju gde je .3.0/24 i ko je gw.
[ dragansar @ 04.07.2017. 22:00 ] @
Evo ti na slici primjer sa jedne mreze koja je skoro identicna tvoj topologiji

L27 i L28 su Linkovi kao i u tvom slucaju izmedju rutera R5 i R6
Posto imas link koji hoces da imas naravno u administraciji i ne mozes 4 adrese pokriti sa mrezom /30 mozes sa /29 u ovom slucaju je to 172.16.4.8/29
Linkovima je postavljen default gateway adresa koje vodi prema strani gdje se nalazi backbone area, posto je ovo isjecak iz area4...tj adresa sa R5 sa interfejsa eth4 172.16.4.9 je gat za linkove.
Na ruterima R5 i R6 je oglasena mreza 172.16.4.8/29 i to je to... imas administraciju nad linkovima i rute oglasene...znaci nema potrebe za redistribucijom jer onda on redistribuira sve statistke ili sve direkno konektovane rute...

Recimo ako dizajniras i planiras da imas areu koja nije backbone onda planiras da na ABR-u sumiras rute...npr ovde je mreza 172.16.4.0/24 odredjena za areju4 i dovoljna je za sve linkove u njoj...zato sam te pitao sto ti je na linku izmedju mreza /24...
Onda ti ruteri u backbone areji dobiju jednu sumirani rutu za svaku areju koju imas, a ne da dobijaju svaku iscjepanu rutu ili mnogo vise ruta ako ih nisi dobro isplanirano :)

Eto nadam se da sam ti pomoga donekle :D

[Ovu poruku je menjao dragansar dana 04.07.2017. u 23:24 GMT+1]

[Ovu poruku je menjao dragansar dana 04.07.2017. u 23:24 GMT+1]
[ viss02 @ 06.07.2017. 23:28 ] @
Pomoglo mi je ovo. Kljucna rec je sumiranje ruta.

Nakon citanja o tome, nasao sam ovo: https://wiki.mikrotik.com/wiki/OSPF_and_PPPoE_Setup

Tu mi je paznju skrenulo:
Code:
/routing ospf area range add area=public_110 range 10.0.110.0/24 cost=default advertise=yes


Ja sam primenio to kod mene:
Code:
/routing ospf area range
add area=K2 range=192.168.3.0/24


Sada u routing tabeli na drugim rutrima imam:


Umesto:


.3.1 i .3.10 su IP adrese rutera koji ucestvuju u OSPF-u.
Nadam se da ce ovo pomoci nekome ko sa RIP-a prelazi na OSPF (kao ja )