[ Milan Aksic @ 12.04.2006. 12:07 ] @
Imam ADSL modem "Sagem fast 800-840" koji u vindouzu radi sasvim korektno, i mada deklarativno podrzava i Linuks ipak imam problema da ga konfigurisem ispravno. Na masini je instlran "Slackware 10.2" sa jezgrom 2.4.

Na pratecem CD-u postoji uputstvo koje korak po korak objasnjava proceduru instaliranja upravljackog programa (modula za jezgro i ostalih datoteka) koji se nalazi u istom direktorijumu. Uputstvo je relativno kratko i najveci deo dokumenta zauzimaju slike konzole, pa cu ga preneti ovde:
Citat:

Installation of driver USB under linux

Distributions Mandrake, Fedora Core, SuSE

This document explains step by step the installation of the module eagle-usb
v1.9.9 of the task force eagle-usb.org, a patch Sagem must be applied there to
make this driver compatible with the modems eagle III

Necessary
The installation must be carried out by having the rights of the administrator
'root'.
Compiler GCC must be installed.
The sources of the linux core must be installed.

Installation
Stage 1 - working directory
Start a terminal and place in session root with the order su - (the password
root is required). Copy the file eagle-usb.tgz under the directory /tmp and
unpack it with the order 'tar xzf eagle-usb.tgz'.

Place under the directory lately created, eagle-usb.

Stage 2 - Application of the patch eagleIII
It's now necessary to apply the patch eagleIII-usb.patch so that the driver
eagle-usb can be used with the modems of the EagleIII type. Type the
'./appli_patch' order to carry out the update of the driver sources.

Stage 3 - automatic configuration
The configuration for the compilation of the driver is automatic, it indicates
also the missing modules (ex:kernel sources) where not having the good version
(ex:gcc). To start the configuration place under the directory eagle-usb-1.9.9
and type the order './configure'

Stage 4 - existing package on the system
If your system has an installation of the package eagle-usb, the checking of
eaglectrl, eaglestat, startadsl, stopadsl indicates ' yes ', then you must carry
out a cleaning of the system via the order make uninstall, to see the section
relating to Uninstallation.
On figure 5, the checking indicates ' no', it thus does not have there a package
eagle-usb installed in this example.

Stage 5 - make
it is necessary to launch the compilation of the driver by typing the order
'make'.

Stage 6 - make install
The installation of the driver and its utilities is carried out by typing the
order 'make install'.

You can remove the directory eagle-usb and the file tgz.

Stage 7 - eagleconfig
Your driver is compiled and installed, connect your USB modem and connect ADSL
line.
Type the order 'eagleconfig' to configure your modem with the parameters of your
ADSL line.

Eagleconfig proposes a list of the ISP with their Vpi, Vci encapsulation
parameters

Select your ISP, in figure 14 one selects Polish ISP TPSA, type your username
and your password, indicate if the password can be encrypted before its sends to
the supplier, connection can be carried out with starting what avoids placing in
root to launch 'startadsl'.

Launch ADSL connection with the order 'startadsl', connection is active, you can
use your navigator preferred to connect you to Internet.


Dakle kao sto sam napisao, instalacija dobro zavrsi, ali problemi pocinju od sedmog koraka. Naime, kada pokrenem "eagleconfig" dobijam sledeci izbor:
Code:

==============================================================================
============================= ADSL Configuration =============================
==============================================================================
Your modem has to be plugged before proceeding.
You can stop this script anytime with [Ctrl][c]

Choose a network configuration :
_______________________________________________________________________
 . . . Country. . . Network. . . . . . . . . VPI VCI ENC
-----------------------------------------------------------------------
AT01 : Austria      ????                     01  20  06  PPPoA VC
BE01 : Belgique     Belgacom, Tiscali.be     08  23  06  PPPoA VC
BR01 : Brasil       Speedy/Telefonica        08  23  01  PPPoE LLC
BR02 : Brasil       Velox/Telemar            00  21  01  PPPoE LLC
BR03 : Brasil       Turbo/Brasil Telecom     00  23  01  PPPoE LLC
BR04 : Brasil       Rio Grande do Sul (RS)   01  20  01  PPPoE LLC
BG01 : Bulgaria     BTK POTS                 00  23  01  PPPoE LLC
BG02 : Bulgaria     BTK ISDN                 01  20  01  PPPoE LLC
DK01 : Denmark      ????                     00  65  03  Routed IP LLC
DE01 : Deutschland  DT (D.Telecom, 1&1...)   01  20  01  PPPoE LLC
ES01 : Espa  Telefonica               08  20  01  PPPoE LLC
ES02 : Espa  Telefonica               08  20  03  Routed IP LLC
ES03 : Espa  Retevision, Eresmas...   08  23  06  PPPoA VC
ES04 : Espa  Tiscali                  01  20  ??  ????
FI01 : Finland      Sonera                   00  64  03  Routed IP LLC
FR01 : France       FT (Free, Wanadoo...)    08  23  06  PPPoA VC
FR02 : France       FT (Free, Wanadoo...)    08  23  01  PPPoE LLC
FR03 : France       Tiscali 128k             08  23  05  PPPoA LLC
FR04 : France       Free d  08  24  04  Routed IP VC
FR05 : France       9online d  08  23  06  PPPoA VC
FR06 : France       Club-internet, t  08  23  06  PPPoA VC
FR07 : France       Tiscali.fr 512k          08  23  06  PPPoA VC
GR01 : Greece       ????                     08  23  06  PPPoA VC
HU01 : Hungary      Matav                    01  20  01  PPPoE LLC
IE01 : Ireland      ????                     08  23  01  PPPoE LLC
IT01 : Italia       Telecom Italia, Tiscali  08  23  06  PPPoA VC
IT02 : Italia       MClink                   08  4B  ??  ????
IT03 : Italia       Telecom Italia office    08  23  03  Routed IP LLC
NL01 : Netherlands  KPN                      08  30  06  PPPoA VC
PL01 : Polska       Telekomunikacja Polska   00  23  06  PPPoA VC
PL02 : Polska       TPSA                     00  35  01  PPPoE LLC
PT01 : Portugal     PT                       00  23  01  PPPoE LLC
SE01 : Sweden       Telia                    08  23  01  PPPoE LLC
CH01 : Switzerland  ????                     08  35  03  Routed IP LLC
CH02 : Switzerland  BlueWin (Swisscom)       08  23  05  PPPoA LLC
UK01 : UK           BT (Tiscali...)          00  26  06  PPPoA VC
-----------------------------------------------------------------------

E sada, nakon instalcije upravljackog programa u Vindouzu, da bi bio ispravno radio uglavnom je bilo potrebno samo da se iz padajuce liste izabare "PPPoE LLC 8/35" (kasnije sam video da ovi brojevi oznacavaju VPI i VCI) kako u listi iznad u Linuksu, nisam pronasao stavku u kojoj pise VPI: 8, VCI: 35 PPPoE izabrao sam prvo "PL02 : Polska TPSA 00 35 01 PPPoE LLC" a kasnije i "CH01 : Switzerland ???? 08 35 03 Routed IP LLC" medjutim kada pokrenem "startadsl" nista se ne desava (niti se vraca u konzolu) pa moram rucno da ga prekinem nakon cega, naravno prijavljuje "Failed to launch connection!".

Pretpostavljam da je najodogovrnija konfiguraciona datoteka na lokaciji "/etc/eagle-usb/eagle-usb.conf" ciji je sadrzaj ovakav:
Code:

#POTS FOR EAGLE
OPTN0=80020066
OPTN4=00000000

#Enable OPTN16 for WT-062 testing only
#OPTN16=80818040
VPI=00000000
VCI=00000035
#Note that the following value for encapsulation is in hex and define
#values in Konst.h are decimal. For example value for PPPOA_VC in 
#header file is 6 decimal which is 6 in Hex, therefore if we want to use
#PPPOA_VC then we should put 6 in the following line for Encapsulation
#The following values are valid for encapsulation :
#MPOA_MODE_BRIDGED_ETH_LLC ----> 1
#MPOA_MODE_BRIDGED_ETH_VC  ----> 2
#MPOA_MODE_ROUTED_IP_LLC   ----> 3
#MPOA_MODE_ROUTED_IP_VC    ----> 4
#MPOA_MODE_PPPOA_LLC       ----> 5
#MPOA_MODE_PPPOA_VC        ----> 6
Encapsulation=00000001
#You must set Linetype to 10 To be able to get CMV values from CMV text files
#If you set Linetype to anything other than 10 then driver gets CMVs from 
#this file. And also if there is no CMV text file for any reason then
#driver gets CMVs from this file as well
Linetype=00000001
RatePollFreq=00000009
STATIC_IP=none
ISP=PL02
LANG=en
ASYNCHRONOUS_START=1

Pokusavao sam da VPI postavim na 00000008 medjutim ni to nije pomoglo.

Program "lsmod" pokazuje da je modul vec ucitan:
Code:

$ lsmod |grep -i eagle
eagle-usb             110916   2
usbcore                59148   1  [acm eagle-usb uhci]

a "ifconfig" da je "eth0" interfejs startovan:
Code:

$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:60:4C:F3:70:9A
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:168 (168.0 b)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:100 (100.0 b)  TX bytes:100 (100.0 b)


Da li neko zna u cemu je problem ili ima neki savet?
[ parafora @ 09.05.2006. 15:44 ] @
kako u tom fajlu treba da se nalazi hex vrednost za VPI i VCP treba staviti:
VPI=00000008
VCI=00000023 (jer je 23hex = 35dec)
e sad Encapsulation treba staviti pppoe llc koji je br. jedan na ovoj listi koju si pasteovao pa bi trebalo da ostavish na 1

nadam se da je ovo pomoglo... i da... skini 2.3.2 verziju sa eagle sajta... ovo ti je prastara verzija i radi samo na 2.4 kernelu (mislim na 1.99 koja je na sagem sajtu i koju si verovatno skinuo)

ja josh uvek nisam uspeo da ga poteram ali nadam se da cu uskoro pa cu baciti izveshtaj... u svakom sluchaju ako si to vec uradio bac izveshtaj ovde
pozdrav
Duja
[ parafora @ 09.05.2006. 19:20 ] @
uspeo sam ga instalirati...
nadji paket rp-pppoe koji ti verovatno nije instaliran
instaliraj eagle-usb 2.3.2
[ sajberista @ 10.05.2006. 20:52 ] @
Parafora da li mozes da iskopiras svoj config posto ja imam slican problem kao Milan?
[ parafora @ 11.05.2006. 08:54 ] @
evo ga /etc/eagle-usb/eagle-usb.conf:
Code:

<eaglectrl>
VPI=00000008
VCI=00000023
Encapsulation=00000001
Linetype=00000001
RatePollFreq=00000009
</eaglectrl>
STATIC_IP=none
ISP=beotel
LANG=en
ASYNCHRONOUS_START=1


morash pre startadsl da poterash eaglectrl -d i eaglectrl -w
pozdrav
[ RadovanBG @ 26.05.2006. 20:51 ] @
Da ne otvaram novu temu... Ali, da li je neko uspeo da potera Sagem Fast 800 na SuSE 10 64BIT? .. I kako?
[ SashaNBG @ 29.11.2006. 21:50 ] @
Društvo, može li neko KONKRETNO u par redova da napiše tačno šta treba da se uradi, jer nismo svi hakeri i ne znamo ono što se vama podrazumeva. Pokušavao sam 2 sata da namestim modem uz pomoć ovog uputstva, ali nikako nisam uspeo da pokrenem ADSL (startadsl prijavljuje gresku - "Failed to initialize" ili tako nesto).


> nadji paket rp-pppoe koji ti verovatno nije instaliran
>

Kopao sam po sistemu i nasao neki takav fajl, izmenio i prebacio u ppp ali nije pomoglo. Na kraju sam uradio "make uninstall" i sad sam na Windows-u.


Primer kako bi to trebalo da izgleda:

- skini fajl eagle-usb-2.x.x.tar.gz sa adrese: blablabla..
- otpakuj u folder /tmp/eagle-usb-2.x.x
- otvori Terminal i kucaj su pa šifru, cd /tmp/eagle-usb...
- kucaj make install
...

znaci da se ništa ne podrazumeva (npr. otpakivanje sa tar -ovo -ono)...


Beotel nema modeme sa ethernet priključkom nego je Sagem 800 jedini izbor, pa Linux (Fedoru) ne palim (a verovatno i mnogi drugi) samo zato što mi je sve vezano za internet. Pomagajte!
[ Amater011 @ 10.12.2006. 21:51 ] @
Meni je Neobee dao USRobotics 9001 ADSL Ethernet modem tako da nisam morao mnogo da se petljam sa tim jeftinim USB modemima...
[ panorama011 @ 23.12.2006. 15:56 ] @
Kada pokrenem eagleconfig (nakon sto unesem user, pass, etc) dobijem poruku:
Code:
Loading DSP & options...               [ Error ]

Zna li neko u cemu je problem? Sta uopste znaci "DSP & options" ?
Hvala.
[ knjigor @ 02.01.2007. 17:55 ] @
Jel uspeo neko da namesti ovaj modem pod Kubuntuom 6.06, ja pokusavam da ga namestim već par nedelja, ali nikako da uspem
[ sglogin @ 07.03.2007. 12:39 ] @
Kod mene je SAGEM [email protected] 1201 zakacen na USB.

Ubuntu Edgy Eft 6.10 je bez ikakvih dodatnih podesavanja (bez instaliranja drajvera) proradio
[ filip_mc @ 11.04.2007. 19:23 ] @
Citat:
sglogin: Kod mene je SAGEM [email protected] 1201 zakacen na USB.

Ubuntu Edgy Eft 6.10 je bez ikakvih dodatnih podesavanja (bez instaliranja drajvera) proradio


A kako si se konektovao, mislim sta kucas u terminalu ili sta vec pokrenes da podesis parametre i otvoris vezu?
[ damird @ 12.04.2007. 20:33 ] @
i ja sam na telekomu sa istim modemom kao sglogin i nista ne ukucavas nego si odmah konektovan na net. modem (pardon ruter) mi je preko mrezne povezan sa racunarom. probao sam vise linuxa (knoppix (3.7 i 5.1), red hat 5, suse... i svi su radili beskprekorno. sto je najgore sve linuxe sam instalirao preko virtuelne masine (vmware) i nikakvih problema nije bilo. poz
[ filip_mc @ 12.04.2007. 21:43 ] @
Eh, da, nekada sam i ja imao izlaz na net preko etherneta, bilo koji linux automatski prepoznaje mreznu karticu, tako da je veza odmah uspostavljena. Medjutim, problem je sto moj modem ima samo USB port, pa su, cini mi se, potrebni dodatni dravjeri (ueagle-atm, konkretno za Sagem) da bi OS prepoznao modem. Nisam jos pokusavao da ih instaliram, pa me stoga zanimalo kako na Ubuntu-u bez dodatnih podesavanja uspostaviti vezu ka internetu?!
[ pyc @ 10.05.2007. 20:39 ] @
Citat:
sglogin: Kod mene je SAGEM [email protected] 1201 zakacen na USB.
Ubuntu Edgy Eft 6.10 je bez ikakvih dodatnih podesavanja (bez instaliranja drajvera) proradio


Nesto mi je tesko da poverujem u ovo posto sam probao doduse Ubuntu 7.04 sa navedenim ruterom zakacenim na USB i nema sanse da ga vidi sam... A koliko vidim nema nista na tu temu ni na netu...
[ loading_off @ 20.07.2007. 21:10 ] @
Imam SAGEM [email protected] 1201 i imam problem sa konekcijom. Povezem modem prema slici i on radi kako valja...ali kada pingujem neki server, posle 20-tak poslatih paketa pise ovako...REQUEST TIMED OUT...Pa bih molio da mi objasnite o cemu se radi i kako da to fixiram...Unapred TNX...
[ combuster @ 22.07.2007. 18:06 ] @
Slackware 12.0 i Sagem Fast 800 E4, upravo namesten....
Instalacija: - ovako je komplikovano samo za Eagle IV chipset

jedini drajver koji radi i koji ne koci a moze da se instalira na kernel-u > 2.6.20 je onaj iz svn repozitorijuma: skinite sa interneta arhivu ueagle-atm-svn-20070330.tar.gz, raspakujte je, klasican make && make install i finito sa drajverom. Kombinacija dsp fajlova koja je uspela da prodje kao firmware za E4 je kombinacija iz fajlova ueagle4-data-1.0.tar.gz i ueagle-data-1.1.tar.gz. Raspakujete ove arhive u direktorijum /lib/firmware/ueagle-atm. Ucitate drajver sa modprobe ueagle-atm... (obavezno proverite da li je make install zamenio stari ueagle-atm.ko sa novim, nalazi se u usb/atm direktorijum u source-u).

posto ipak komanda za reset na ovom drajveru ne funkcionise, kada pokrenete dmesg|grep ueagle i ako ne pise na kraju kada modem izblinka svoje "modem operational" morate da ishtekate modem i da ga ushtekate opet, dok se firmware ne ucita.

sada se mora napraviti konekcija i to bridge-ovana preko nas0 interface-a sa br2684 modulom i aplikacijom br2684ctl. Ovo je bas izobjasnjavano na netu i iz mnogih pdf-ova tako da to ovde nema potrebe da se pominje opet. Kada podignete nas0 sa ifconfig nas0 up treba instalirati rp-pppoe plugin: meni je kompajliranje source-a iz arhive rp-pppoe-3.8.tar.gz odradilo posao... pokrenete zatim pppoe-setup, pa pppoe-start a zatim i pppoe-status ako vas zanima da li ste prosli... Sve ove arhive mozete naci na netu pa gooooglajte...
[ SashaNBG @ 23.07.2007. 10:46 ] @
Combuster,

pa lakše je da napravim novi modem nego to sve da uradim! :D

Stvarno nije čudo što Linux nije mnogo zastupljen po kućama, treba da si haker da upalis modem, c,c,c!

U svakom slučaju, hvala na pomoći! Ja sad idem preko rutera na net pa mi ne treba više takvo akanje oko modema.

Pozdrav!
[ combuster @ 24.07.2007. 12:38 ] @
Cuti, ja sam pukao bio kao lajsna... Taman sam hteo da odem i da kupim neki adsl router kad ono posle neprospavane noci prodje... Ma na netu i sami tipovi sto pisu drajvere za usb adsl modeme kazu " Momci, ako ne zelite oci da ostavite na monitoru i da vas make sa 10 switch-eva i kompile error-i nocu bude u znoju kupite adsl router..."... Jeste zeznuto, kad sam polagao c iz programskih jezika u pola noci me budio kosmar sa gomilom pointera i nizova... :-D Sto je najgore, sta god u Linux-u da otvoris sve sam c kod... :-( A dok ispratis gomilu datoteka zaglavlja... Pobegao sam od teme... Kome treba pomoc za Sagem [email protected] 800 E4 neka pise na [email protected]
[ tandarela @ 01.08.2007. 13:55 ] @
Pozdrav ljudi!

Evo pre 2 dana sam stavio OpenSUSE 10.2 i naravno imam eunetov Sagem Fast 800-840. Jurim po netu uputstva za instalaciju i nasao sam sve i svasta. Nekako sam uspeo da dignem modem :
"dmesg" mi izbacuje "Modem operational" poruku, a "lsmod |grep -i eagle" mi izbacuje da su ucitani svi potrebni drajveri ( atm, ueagle_atm, firmware_class i usbcode ).

Posle toga sam opet zapeo na sledecem :
Ne mogu konekciju da napravim.

@combuster :
Ti si u postu od 18.07. ( http://www.elitesecurity.org/t275923-Sagem-ST-Mandriva-free ) naveo instalaciju i povezivanje unutar mandrive, a u postu od 22.07. ( ovde ) naveo podesavanje za slack. U ta dva posta uspostavljanje konekcije se vrsi na 2 razlicita nacina. Sad sam malo zbunjen...
Probao sam ovaj sa br2864 drajverom. Kucam "modinfo br2864" i izbaci da drajver postoji u sistemu. Kucam "modprobe br2864 " i posle "lsmod |grep -i 2864" i tu mi izbaci da je isti pokrenut. Medjutim kada kucam "br2864ctl" da napravim interfejs izbaci da komanda ne postoji i to je kraj.

Sa ueagle sajta sam skinuo neko uputstvo za pravljenje i pokretanje konekcije :

Code:

Pokretanje
----------
poziva se nakon sto je modem instaliran i u operativnom stanju ( to je kod mene slucaj ) :
# pppd call eunet >/home/pppd.log
izbacuje :
# Plugin pppoatm.so loaded.
# PPPoATM plugin_init
# PPPoATM setdevname_pppoatm - SUCCESS:8.35
# Using interface ppp0
# Connect: ppp0 <--> 8.35
# Hangup (SIGHUP)
# Connection terminated.
# Modem hangup
zatim se ovih 5 linija stalno ponavljaju
# Using interface ppp0
# Connect: ppp0 <--> 8.35
# LCP: timeout sending Config-Requests
# Connection terminated.
# Modem hangup


Podesavanje
------------
# eunet fajl
user "[email protected]t"
plugin pppoatm.so 8.35
llc-encaps
noipdefault
usepeerdns
defaultroute
persist
noauth


Takodje, yast mi ne detektuje ADSL modem.

Do sada nisam radio u linuxu na ovom nivou, pa je svaka pomoc dobrodosla...




[Ovu poruku je menjao tandarela dana 01.08.2007. u 16:54 GMT+1]
[ combuster @ 01.08.2007. 23:17 ] @
br2684 modul je standradni deo kernel-a 2.6.xx i on se ucitava sa modprobe br2684 bez potrebe za kompajliranjem source-a... To si video i sam. Elem, aplikacija br2684ctl zavisi od libatm biblioteke i nju moras da instaliras. Ako je prisutna u tvojoj instalaciji suse-a ok ako nije moras da je sam ubacis. Ja sam skinuo sa neta rpm sa tom bibliotekom i pomocu rpm2tgz na slack-u sam je prebacio u tgz i iskopirao u usr/lib. Ako ti za br2684ctl prijavljuje da ne postoji komanda, moras da je onda pokrenes kao root ili ti nije u putanji gde su ti binaries (/bin, /sbin, /usr/bin, /usr/sbin, /usr/local/bin, /usr/local/sbin). Ta aplikacija nije standardni deo paketa bilo koje distribucije (osim debian-a i think) pa je moras skinuti sa neta i iskopirati u jedan od ovih direktorijuma gde su ti izvrsni fajlovi... Pokreces je sa "br2684ctl -b -c 0 -e 0 -a 8.35". Kada to uradis kreirace ti nas0 interface koji zatim treba podici sa komandom "ifconfig nas0 up". E sada deo koji je mene mucio mnogo. Kako znas i sam da PPPoATM sljaka kod doticnog modem-a i da on nema eth port, ja sam mislio da konekcija pomocu pppd-a odradjuje posao. Ali nas0 ne shljaka preko PPPoA plugin-a nego preko PPPoE plugin-a. Zato moras da skines i rp-pppoe-3.8.tar.gz sa net-a i da ga iskompajliras (kada ga raspakujes idi direktno u source ili src direktorijum a instalacija ide klasicno pod root nalogom: ./configure && make && make install), gde prvo kada to zavrsis pokreces pppoe-setup, odgovoris na par pitanja a zatim cepnes pppoe-start i konektovan si.
Kazem ti najgadnije od svega je podesiti konekciju. Recimo ovaj postupak pod Fedorom 7 Moonshine ne radi kako treba. Modem radi, drajveri su ok, kada pokrenem konekciju on ceka i ceka i ceka i nista se ne desava. Zato sam fedoru boot-ovao (my boot accidentaly steped on fedora dvd :-)) Sa istim postupkom to radi pod Mandrivom i Slackware-om kao bombona (za razliku od windowza ne puca veza iako ostanes konektovan i po 4-5 dana i noci)... Javi za SuSe kako je proslo i da resimo ako ima problema! Good luck!
[ tandarela @ 02.08.2007. 19:46 ] @
Sa zadovoljstvom se posle 4 dana mucenja javljam iz OpenSUSE 10.2 linuxa. Uspeo sam da podesim sve i naravno podelicu iskustvo sa vama.

Trazeci u Google rp-pppoe-3.8.tar.gz program naleteo sam na neki ceski sajt sa od A do SH objasnjenjem kako podesiti Sagem Fast 800 usb modem pod SUSE 10.1 . Obzirom da se ne secam sa kog sajta sam skinuo to, ovde naglasavam da postupak nije moj.

Citat:

1-. Download modem firmware
ueagle-data-1.1.tar.gz
Unpack and files copy to
/lib/firmware/ueagle-atm

2- Over YaST check if we have installed next packages
ppp
libpcap
flex
linux-atm-lib

3- Install
rp-pppoe-3.8.tar.gz
Unpack and install by command
./go
During installation we must set next parameters:
username:
password:
interface: nas0
primary dns: 194.228.41.65
secondary dns: 194.228.41.113
connection on startup: no

4- Download execute file
br2684ctl
and install it
install -m 744 br2684ctl /usr/sbin

5- In files
/etc/ppp/chap-secrets
and
/etc/ppp/pap-secrets
we must set our username and password
"username" * "password"

6- Download file
ueagle-atm
and copy to
/etc/ppp/peers/
The file
ueagle-atm
contains following:
user "username"
plugin rp-pppoe.so
nas0
noipdefault
usepeerdns
defaultroute
persist
noauth

Instead
"username"
we must set our username, in my case phone number

7- Create file
/var/run/ppp/resolv.conf
In this file set DNS servers
nameserver 194.228.41.65
nameserver 194.228.41.113
and make simlink to file
/etc/resolv.conf
ln -s /var/run/ppp/resolv.conf /etc/resolv.conf

8- Download script
adsl
that contains following:

#!/bin/sh
modprobe br2684
modprobe ppp_generic
modprobe pppoe
br2684ctl -c 0 -b -a 8.48 # 8.35 je za eunet
ifconfig nas0 up
pppd call ueagle-atm

and install it
install -m 744 adsl /usr/sbin

9- Connect the modem by call script
adsl


Ja sam u bunilu stavio jos i ueagle-atm-1.3.tar.gz cime sam uspeo modem da dignem ali ne i konekciju, ali to nije pravilo problem.

E sad, obzirom da sam ja na BGWireless mrezi, a izlaz na net imam preko sopstvene konekcije, objasnjenje gore mi nije bas do kraja pomoglo, obzirom da je potrebno dodati rute. ueagle-atm fajl ima liniju viska i to je " usepeerdns ". Takodje, potrebno je u resolv.conf dodati i DNS mreze pre DNSova internet provajdera. Samo dodavanje rute vrsim nakon povezivanja na net ( nece drugacije ) :
Code:
route add -net 10.0.0.0/8 gw 10.5.33.129


Ja se nadam da ce ovo nekom koristiti.

Napomena : Svi gore navedeni fajlovi imaju da se skinu na netu, samo je potrebno naci ih preko google-a.

@combuster : Hvala puno!!! Mozda bi moglo jos da se odradi da se adsl dize sa sistemom? To mi bas i nije uspelo :
U boot.local fajl ( SUSE zamena za rc.local ) sam dodao sadrzaj adsl fajla i posle toga jos liniju za rutu. Rezultat je da u root nalogu radi mreza, a u ne root nalogu radi internet :D, a da pri dodavanju rute rucno iz root terminala izbacuje gresku.
To nije toliko bitno ali je to ona hands-free finesa...

POZDRAV!




[Ovu poruku je menjao tandarela dana 02.08.2007. u 21:38 GMT+1]
[ combuster @ 02.08.2007. 22:39 ] @
Za wireless ne mogu da pomognem jer nisam imao nikakva iskustva sa wireless mrezama. A sto se tice ovog uputstva koje si nasao nisu mi jasne dve stvarcice. Zasto je uopste potrebno pozivanje ueagle-atm sa pppd kada se pokrece rp-pppoe sa komandom ./go? Ona dize gui za podesavanje konekcije pomocu koje se i konektujes na net pa ti ueagle-atm konekcija uopste ne treba. Koji sagem imas? Ako je E4 onda ne znam kako ti radi sa firmware-om iz ueagle-data-1.1.tar.gz? Meni sa tim firmware-om prodje jednom u 5 pokusaja, dok sa ueagle4-data prolazi svaki put... Mada cuti brate - bitno je da to radi!!! Sad ghost i surf all day long! A pokretanje konekcije ne sme da ide u startup zato sto modemu treba vremena da ucita firmware (ume da potraje i do 20-ak sekundi) pa nema smisla pokretati konekciju pri boot-ovanju. Ja sam u rc.local tutnuo modprobe br2684 i br2684ctl -b -c 0 -e 0 -a 8.35 i ifconfig nas0 up a sam rucno pokrecem pppoe-start. U svakom slucaju, svaka cast! Jos kad budem imao vremena da vidim u cemu je problem sa Fedorom 7 i da ispostujemo jedan manual u pdf-u i bice super... GreetZ!
[ tandarela @ 03.08.2007. 01:46 ] @
Citat:
A sto se tice ovog uputstva koje si nasao nisu mi jasne dve stvarcice. Zasto je uopste potrebno pozivanje ueagle-atm sa pppd kada se pokrece rp-pppoe sa komandom ./go? Ona dize gui za podesavanje konekcije pomocu koje se i konektujes na net pa ti ueagle-atm konekcija uopste ne treba. Koji sagem imas? Ako je E4 onda ne znam kako ti radi sa firmware-om iz ueagle-data-1.1.tar.gz? Meni sa tim firmware-om prodje jednom u 5 pokusaja, dok sa ueagle4-data prolazi svaki put...


Pazi, uputstvo koje sam postavio na vrhu stranice naznacava <h1></h1> slovima da je u pitanju SUSE 10.1, a ne linux generalno. Kada kucam komandu "./go" ne dize mi se GUI ( ./go-gui je valjda za to ), vec mi se u terminalu pokrece kao wizard u kome se unose svi podaci koji su u uputstvu navedeni. Koliko sam shvatio, u tom slucaju rp-pppoe kreira resolv.conf fajl, u njega pise DNS adrese i u pap i chap unosi login podatke. Zato se kasnije shodno tim podesavanjima konekcija dize sa pppd. Sagem koji imam nije E4 ( instalacija drajvera u win kaze da je Sagem Fast 800-840 ).

Citat:
A pokretanje konekcije ne sme da ide u startup zato sto modemu treba vremena da ucita firmware (ume da potraje i do 20-ak sekundi) pa nema smisla pokretati konekciju pri boot-ovanju. Ja sam u rc.local tutnuo modprobe br2684 i br2684ctl -b -c 0 -e 0 -a 8.35 i ifconfig nas0 up a sam rucno pokrecem pppoe-start.


Isto sam uradio, mada kad u terminalu kucam "pppd call ueagle-atm" meni se konekcija digne posle 3 sekunde, a sam modem se digne pre toga. Zato me je i zbunilo to "klanje" sa mrezom u bootu. Nazalost, svaki put moram da kucam pppd, pa posle route add da bi mi sve radilo. Naci cu vec nacin kako to da automatizujem, bitno da sad radi !!!

Citat:
U svakom slucaju, svaka cast! Jos kad budem imao vremena da vidim u cemu je problem sa Fedorom 7 i da ispostujemo jedan manual u pdf-u i bice super...


Stavimo na wikipediu ;)

Pozdrav!

[Ovu poruku je menjao tandarela dana 03.08.2007. u 03:12 GMT+1]
[ combuster @ 03.08.2007. 08:09 ] @
Citat:
Sagem koji imam nije E4 ( instalacija drajvera u win kaze da je Sagem Fast 800-840 ).

Okreni modem naopacke, na stickeru ti pise da li je E2, E3 ili E4. Ima bas dosta veze zbog firmware-a koji koristis.

Citat:
Kada kucam komandu "./go" ne dize mi se GUI ( ./go-gui je valjda za to )

Sorry, totalni mix up...

Citat:
Nazalost, svaki put moram da kucam pppd, pa posle route add da bi mi sve radilo. Naci cu vec nacin kako to da automatizujem, bitno da sad radi !!!

Jos nisam imao potrebe za tako nesto ali sto ne napravis prostu shell skriptu, napravis ikonicu za nju na desktop-u i eventualno ako ti trebaju administratorska prava dodaj u command line-u kada pravis sortcut su -u...

Najgore od svega je sto u zavisnosti od kernela i distribucije se javljaju drugaciji dep-ovi i potrebne su druge verzije drajvera i firmware-a (o verzijama eagle chipset-a koje se nalaze u modemu da i ne govorim, mada je za E1 E2 i E3 sve isti drajver i firmware, dok se za E4 razlikuje)... To bas otezava pisanje uputstva (mada ako to odradimo, posaljemo ga sagem-u sa sve drajverima i dep-ovima da izbaci na sajt umesto onog njihovog koji nece ni da se kompajlira) :-D...
[ tandarela @ 03.08.2007. 19:52 ] @
Dobro onda, okrenuh modem i kaze "Sagem Fast 800 E3"

Kada je u pitanju pisanje uputstva, moze da se odradi i deo za rutiranje tj. ukoliko je korisnik i na mrezi da bude kompletno.

[ combuster @ 03.08.2007. 22:23 ] @
Zato ti i radi ueagle-data-1.1 firmware. Da imas E4 ne bi to islo tako... :-) Posto ja blage veze nemam oko wireless-a, ako budem odradio uputstvo za slackware i ti za suse, dodaj i deo za rutiranje... greetZ
[ parafora @ 21.08.2007. 05:08 ] @
@combuster

samo svratih da ti se zahvalim...
da mi nisi skrenuo paznju na onaj linux-atm paket sa svn-a josh bih bio na slacku 10.2 :)
pozdrav
[ parafora @ 22.08.2007. 01:40 ] @
@ combuster

nije potrebno da stalno cupas modem i ukljucujesh ga
samo pokrenu ovu skriptu kada podignesh sistem i sve ce raditi

Code:

#!/bin/bash
rmmod ueagle_atm
modprobe ueagle_atm
sleep 20
br2684ctl -b -c 0 -e 0 -a 8.35
ifconfig nas0 up
pppoe-start



to sam nazvao adsl i dao mi mogucnost izvrshavanja (chmod +X adsl), prekopirao u /usr/sbin da mogu da pokrecem lakse i to je to...

poz
[ 1553040 @ 28.09.2007. 10:36 ] @
Treba i meni pomoć oko podešavanja modema, sa tom razlikom da je moj sagem modem model E4, tj. SAGEM FAST 800 E4, pa tako ne mogu pratiti vaša uputstva. Treba mi pomoć prvenstveno zbog toga što se ne mogu lako naći u LINUX OS, jer ga prvi put u životu upotrebljavam, pa vas molim da mi pomognete.

PoZz
[ combuster @ 28.09.2007. 13:41 ] @
Slackware 12.0 i Sagem Fast 800 E4, upravo namesten....
Instalacija: - ovako je komplikovano samo za Eagle IV chipset

jedini drajver koji radi i koji ne koci a moze da se instalira na kernel-u > 2.6.20 je onaj iz svn repozitorijuma: skinite sa interneta arhivu ueagle-atm-svn-20070330.tar.gz, raspakujte je, klasican make && make install i finito sa drajverom. Kombinacija dsp fajlova koja je uspela da prodje kao firmware za E4 je kombinacija iz fajlova ueagle4-data-1.0.tar.gz i ueagle-data-1.1.tar.gz. Raspakujete ove arhive u direktorijum /lib/firmware/ueagle-atm. Ucitate drajver sa modprobe ueagle-atm... (obavezno proverite da li je make install zamenio stari ueagle-atm.ko sa novim, nalazi se u usb/atm direktorijum u source-u).

posto ipak komanda za reset na ovom drajveru ne funkcionise, kada pokrenete dmesg|grep ueagle i ako ne pise na kraju kada modem izblinka svoje "modem operational" morate da ishtekate modem i da ga ushtekate opet, dok se firmware ne ucita.

sada se mora napraviti konekcija i to bridge-ovana preko nas0 interface-a sa br2684 modulom i aplikacijom br2684ctl. Ovo je bas izobjasnjavano na netu i iz mnogih pdf-ova tako da to ovde nema potrebe da se pominje opet. Kada podignete nas0 sa ifconfig nas0 up treba instalirati rp-pppoe plugin: meni je kompajliranje source-a iz arhive rp-pppoe-3.8.tar.gz odradilo posao... pokrenete zatim pppoe-setup, pa pppoe-start a zatim i pppoe-status ako vas zanima da li ste prosli... Sve ove arhive mozete naci na netu pa gooooglajte...

Ovo si imao na prvoj stranici :-D

Ne treba ti ueagle-data-1.1.tar.gz za E4 chipset vec samo ueagle4-data-1.0.tar.gz. Trebalo bi popodne da napisem konacno taj tutorial za sagem E4 od a do z korak po korak pa ako ti ovo ne pomogne onda ce ti taj pomoci sigurno... Pozdrav!
[ nikolica_84 @ 26.04.2008. 00:16 ] @
A jel uspeo neko da ovo potera preko USB-a na Ubuntu-u 8.04??? Ne hvalim se, nego molim za pomoc... :D
[ Dragche @ 22.05.2008. 09:52 ] @
Juče sam instalirao Ubuntu 8.04 (ovo mi je prvi susret sa Linux-om). Moj modem je Sagem Fast 800/840 A4 (od EUnet-a). Sto se tiče drajvera ovo definitivno radi www.ubudsl.com/en/download.php, jedino sam imao problem da sistem Ubuntu neće da se podigne prilikom prvog restarta dok je modem bio priključen, ali kada sam ga priključio kasnije sve radi odlično. Korisnici EUnet i Sezampro adsl-a treba samo da odaberu svog provajdera sa liste i ukucaju username i pass, jer je sve automatski podešeno dok ostali moraju "ručno"! Preko UbuDSL takođe možete uvek videti parametre veze (protok , ip..) ,a takođe i status modema ( u desnom gornjem uglu ekrana imate lampicu koja je sinhronizovana sa onom zelenom na modemu)!

Savet za Linux početnike:

Prilikom instalacije Ubuntu 8.04 koristite program http://wubi-installer.org/, jer vrlo jednostavno instalira Ubuntu ne dirajući druge operativne sisteme u mom slučaju XP i Vistu (dual boot), sada mogu da prilikom uključivanja Pc-a ili restarta biram između XP-a Viste i Ubunta (I to Vista i Ubuntu su na istoj particiji, a rade oba bez ikakvih problema).Objašnjenje imate na Wubi-jevom sajtu!

Ako ima pitanja tu sam!

[Ovu poruku je menjao Dragche dana 22.05.2008. u 11:09 GMT+1]