[ [email protected] @ 05.01.2003. 01:58 ] @
Obzirom na to da sam ja na samom pocetku PHP-a ne bih mnogo smarao sa pitanjima pokrenucemo jedan forum pa vremenom ce svako ko ne zna nauciti, a ko zna potvrditi svoje znanje. Dakle:

1.PHP Propusti (poznati i nepoznati)
2.Kako se zastiti ?

Vi ste na redu
[ Goran Rakić @ 05.01.2003. 10:03 ] @
PHP je OpenSource skript jezik, tako da se sve greške preko bugs sistema po uočavanju brzo otkrivaju. Iskoristi poslednju verziju php-a (zbog greške sa buffer overflow-om u wordwrap() funkciji, koja nije baš često korišćena, ja sam je jednom koristio za newsletter), uključi secure mod u php.ini-ju i pazi kakav kod pišeš odnosno koristiš!

I da, da ne bude zabune, PHP i phpBB nije isto! phpBB je forum koji je napisan u PHP-u.
[ [email protected] @ 05.01.2003. 11:57 ] @
Trenutno koristim PHP TRIAD sa Apche verzijom 1.3.14.
Zapelo je kod prevoda PHP NUKE 6.0...
[ Goran Rakić @ 05.01.2003. 12:40 ] @
pa to opet nema veze sa security-jem samog php-a i propustima u njemu. Inače i taj Apache je podosta bušan, a ne znam za verziju php-a koji stiže uz php triad. I da, PHP Nuke se isto nije ubio od sigurnosti, često izbacuju zakrpe (barem u vreme kada sam ga ja pratio, oko verzije 4.5.x)
[ -zombie- @ 05.01.2003. 16:20 ] @
Citat:
Go! X:
wordwrap() funkciji, koja nije baš često korišćena, ja sam je jednom koristio za newsletter


mislim da smo svi ovu funkciju koristili tacno jednom, i to bash za mailove :D


shalim se malo, ali stvarno, bash sam je prekjuce prvi put koristio (a u php-u radim oko 3 god), i to bash za mail. heh!