[ Pauli @ 03.08.2001. 07:41 ] @
Ako postoje instalirane dvije verzije istog paketa na FreeBSDu, da li je sigurno ukloniti stariju verziju?

Npr.: kod mene postoje:

tiff-3.5.4
tiff-3.5.5
png-1.0.5
png-1.0.10
itd.

[ MoHicAn @ 03.08.2001. 21:26 ] @
NEeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee
nikako
bre
nemo se zajebes slucajno

EXPLODIRACE ti komp !!!


[ Pauli @ 03.08.2001. 23:05 ] @
Nismo se razumjeli. :-))

#pkg_delete png-1.0.5
pkg_delete: package 'png-1.0.5' is required by these other packages and may not be deinstalled:

i onda slijedi lista.

To me muci.
[ Dusan Marjanovic @ 04.08.2001. 00:41 ] @
Pa mozda sistem i nije upoznat sa novijom verzijom png-a, probaj da uklonis noviju verziju pa da li ce da ti ponovo javi te probleme sa dependencies, jer ne znam da li si i tu noviju verziju dodavao preko pkg_add ili ne
[ random @ 04.08.2001. 05:32 ] @
Nije sigurno obrisati staru verziju jer možda (čitaj: sigurno) stari i novi paket sadrže neke iste fajlove, koji bi bili obrisani u tom slučaju. Ako ti baš smeta, jedino je sigurno da obrišeš obe, pa da instaliraš samo novu. Pritom, ako neki drugi paketi zavise od tog paketa (kao što npr. čitav KDE zavisi od libpng), onda je jedino rešenje da obrišeš sve te pakete, zatim upgrade-uješ željeni paket, i onda ponovo instaliraš sve obrisane pakete. Ovo je veliki posao, koji ti savetujem da radiš na svakih par meseci, ne češće, taman kad hoćeš da odjednom upgrade-uješ veliki broj paketa (npr. kad izađe nova verzija GNOME-ta ili KDE-a). Možeš da brzo dobiješ listu paketa koji nisu "up-to-date" (pod uslovom da ti je ports stablo ažurno, a nadam se da jeste, jer, ipak, jebeš FreeBSD bez ports stabla ;o)) sledećom komandom

Code:

# pkg_version -v | grep -v = | less


Takođe pročitaj sledeće sekcije iz handbooka, ako već nisi:

http://www.freebsd.org/doc/en_...59-1/books/handbook/ports.html
http://www.freebsd.org/doc/en_...oks/handbook/cutting-edge.htmlpnumTi?

poz.potrebi,