[ zeljkod @ 31.07.2003. 14:42 ] @
Na jednom hard disku sam imao Win XP i Suse 8.2. kada sam hteo da izbirishem Suse, a potom i GRUB loader (na nacin koji je opisan u SUSe help centru), odnosno da iz windows recvovery console uradim fixmbr, nakon reseta racunara pojavila mi poruka o greshki "Invalid partition table".

E sad, kada sam preinstalirao suse i ponovo odabrao Grub, nakon reseta dobio sam mogucnost izbora ili Win ili SUSe, medjutim cim ga izbrishem sa fixmbr dobijam pomenutu poruku.

Da li postoji mogucnost da to popravim bez foramtiranja HDD.

ZED
[ darkside @ 31.07.2003. 16:08 ] @
pa probaj sledece, kada sam instalirao redhat pisalo mi je da ako imas 2k ili XP da je pametnije da ti boot loader i aktivna particija budu na /boot, a ne na master boot recordu, ako nemas problema sa startovanjem wina iz gruba, probaj sa time, mozda je greska toga...
[ zeljkod @ 31.07.2003. 16:12 ] @
Da, probao sam neshto slicno. Postavio sam da se Suse starta sa Floppy diska, ali problem je u sledecem shto jednostvano vishe nisam mogao da startam Windows. Kada sam uradio fixmbr javila se poruka "Invalid partition table".

U principu nije nikakav smor fromatirat HDD, pa "jovo sve na novo" ali imam hiljadu nekih stvari na disku.

[ B o j a n @ 31.07.2003. 19:39 ] @
Ne znam kako stoje stvari sa grub loader-om, ali evo kako bi to uradio sa lilo loader-om, pa mozda ti bude od neke koristi, povuci paralelu ... ili sta vec.

Naime, kada god se upisuje u mbr, lilo napravi backup mbr-a, u vidu fajla ( kod mene je boot.0300 ), gde je 0300 verovatno rdev-like broje particije ), na drugim konfiguracijama moze da varira. I kada ti se $#^^[email protected]&%$ mbr, imas opciju da boot-ujes sa CD-a, i zatim povratis ( ne bukvalno ) stari mbr sa dd if=/boot/boot.0300 of=/dev/hda ) ili koji god ti je disk sa kojeg boot-ujes.

to je sve ...
[ zeljkod @ 01.08.2003. 17:00 ] @
Cini mi se da je to ista komanda (operacija) kao i windowsova "fixmbr", gde on zapravo postojeci menja starim MBR ili u SUSe linuxu - uninstall boot loader.

Poshto sad koristim grub, ne znam shta bi se desilo kada bi grub loader convertovao u Lilo, prilikom reinstalacije Linux-a.
[ darkomi @ 03.08.2003. 01:43 ] @
Taj problem se i kod mene javio, ali sam ga uspesno uklonio pokretanjem fdisk-a, sa win98 boot disk-a i postavljanjem prve (sistemske) particije kao aktivne! Posle toga restartuj komp i sve ce biti ok, bices u windows-u!
[ Goran Mijailovic @ 05.08.2003. 02:30 ] @
Slican problem se i meni desio sa w98 i SuSe 8.2, posle brisanja linux particija W98 nije mogao da se podigne, probao sam sa fdisk /mbr ali to nije pomoglo...
HDD-u se moglo pristupiti iz DOSa sa W98 startup diska...
Na kraju sam uradio fdisk i format c: .....to je pomoglo?!?
A da, loader je bio LILO
[ darkomi @ 05.08.2003. 22:45 ] @
Koliko sam imao prilike da vidim, prilikom podizanja linux-a ( u mom slučaju SuSE8.2 i Slack9 ) dešavalo mi se da linux po default-u markira neku od svojih particija kao aktivnu. prilikom restarta Windows "vidi" dve aktivne particije i neće da se boot-uje. Boot-ovao sam sistem sa win98 bootdisk-om, pokrenuo sam fdisk i samo sam C: stavio da mi bude aktivna particija i tada je profunkcionisalo!
[ Goran Mijailovic @ 06.08.2003. 01:50 ] @
Razumem, samo kazem moje iskustvo ja sam zaboravio da postavim aktivnu particiju...
[ ilDuceo @ 02.08.2008. 17:26 ] @
Imam slican problem i ne znam kako da ga resim. Naime, imao sam instaliran SUSE 11. Pokusao sam da se vratim na XP, formatirao disk, ubacio bootabilan cd... kopiranje proslo u redu, ali kada se prvi put restartovao vratio se opet na kopiranje, cak me nije pitao ni ono standardno "Press any...". Sta da uradim da se Win instalira normalno?
[ nemysis @ 02.08.2008. 19:45 ] @
Citat:
ilDuceo: Imam slican problem i ne znam kako da ga resim. Naime, imao sam instaliran SUSE 11. Pokusao sam da se vratim na XP, formatirao disk, ubacio bootabilan cd... kopiranje proslo u redu, ali kada se prvi put restartovao vratio se opet na kopiranje, cak me nije pitao ni ono standardno "Press any...". Sta da uradim da se Win instalira normalno?


Kao prvo da li imaš particije i kako su podeljene? Koliko memorije imaš i koji Procesor?

Ako particije nisu dobre, moraš izbrisat pa ponovo napraviti paricije, pa ih formatirati. Komande ne znam jer ne znam Windows više, to jest neću da znam.

Ali nešto tipa format :c /s koliko se sećam.

Što ti se ne sviđa SuSE razumem. Mnogo je bolji Gentoo. Ali to neće svako da proba. Probaj bolje Kubuntu, to ti je nešto kao Windows u Linux ruhu. Ne moraš puno da radiš tamo, sve odluke ti uzme sistem kao i u Windows-u. Koristio sam ga 3 godine, ličio mi je na Windows.

Pozdrav nemysis
[ ilDuceo @ 03.08.2008. 15:29 ] @
Dve particije, jedna 15GB druga 65GB. U pitanju je lap, tako da ne znam koja je tacno memorija, uglavnom 1GB na 667, procesor je Core2Duo 1.5. Uspeo sam da resim problem tako sto sam obrisao sve particije, formatirao opet, poceo sa instalacijom wina, otisao u Recovery mod izbrisao GRUB loader komandom fixmbr i fix boot.

A sto se tice linuxa, nije bas tema za tu raspravu, ali pokusao sam sa Ubunuom- ne prepozna mi zvucnu na lapu, SUSE je prepoznao sve i radio je ok, ali se osecam veoma ograniceno. Verovatno je to subjektivni osecaj jer u Winu znam da uradim sve i svasta...