[ Napushenko @ 13.07.2008. 04:09 ] @
Ovo su informacije root-a

Code:
Plesk Control Panel version psa v8.4.0_build84080425.21 os_CentOS 4.2
Operating system Linux 2.6.18-028stab053.6


Probo sam sa yum-om ali uopste nije ni instalova.
Root prima .rpm pakete,ali mi treba gcc.
Jel neko isntalovo gcc ranije na CentOS-u,ako jest molim pomoc.
[ random @ 13.07.2008. 19:00 ] @
# yum install gcc


(pod uslovom da su ti yum repozitorijumi ispravno konfigurisani)
[ nkrgovic @ 14.07.2008. 00:46 ] @
Pa rece covek da mu ne radi sa yum-om? Uglavnom, ako ne radi, prvo proveri repo-e da li su dobro postavljeni. Znaci, /etc/yum.repos.d/*. Drugo, javi sta ti yum baca kao gresku.

Alternativni pristup: Skini gcc rpm za tvoju platformu, pa kreni na ruke:

Code:

# mkdir gcc-install
# cd gcc-install
# wget -c http://omiljeni.yum-centos.mir.../arhitektura/rpms/gcc......rpm
# rpm -ihv *.rpm


Kad kaze:

Fali mi ovo, ovo i ovo - ti to skines, pa probas ponovo. Stavljali su se rpm-ovi i pre yuma :D.
[ Napushenko @ 14.07.2008. 03:24 ] @
random,kako da configures yum kako sto treba?


Code:
-rw-r--r--   1 root root    2657 May  2  2007 warnquota.conf
-rw-r--r--   1 root root   23735 Feb 21  2005 webalizer.conf
-rw-r--r--   1 root root   23930 Feb 21  2005 webalizer.conf.sample
-rw-r--r--   1 root root    4204 Nov  2  2005 wgetrc
-rw-r--r--   1 root root     289 Aug 22  2005 xinetd.conf
drwxr-xr-x   2 root root    4096 Jul 12 07:32 xinetd.d
drwxr-xr-x   2 root root    4096 May  6 14:45 xml
drwxr-xr-x   2 root root    4096 May  6 14:45 yum.repos.d
[[email protected] etc]#



nkrgovic,taj fajl postoji /etc/yum.repos.d/ ne znam ni u cemu je greska ni kako je proveriti,mozesh mi malo pojasnit?
A probo sam i tako sa isntalacijom nekihrpm pageta ali nesto mi kaze %soure not found Red Hat tak nesto ne secam se dobro.

Ako ti nadzes linkov za gcc za CentOS samo ga postaj ja cu ostalo sredit.
[ nkrgovic @ 14.07.2008. 12:36 ] @
To yum.repos.d je, ako obratis paznju na slovo d na pocetku reda, direktorijum, ne fajl. U njemu su ti fajlovi koji su konfiguracija za sam yum, konkretno fajlovi koji mu daju spisak repo-a koje treba da koristi. Ono sto je meni simptomaticno je da nema samog yum.conf fajla.... Ako hoces da ti neko pomogne, pocni od provere da li taj fajl postoji, a bilo bi dobro i da das samu gresku, znaci uradis copy/paste od

# yum install gcc

pa dok ti ne vrati prompt.

Ako hoces na ruke, samo izvoli, imas gcc na centos mirorima. Za centos4 na i386 imas recimo ovde;

http://mirror.silyus.net/centos/4/os/i386/CentOS/RPMS/

Pa skidaj na ruke, ako ti je tako lakse....
[ Napushenko @ 15.07.2008. 13:12 ] @
Code:
[[email protected] etc]# yum install gcc
-bash: yum: command not found


A sa CentOS sajta :

A ove paketi su veoma naporni za instalovat,samo downlodujem i uvijek mi trazi nesto novo.
[ nkrgovic @ 15.07.2008. 14:38 ] @
Vrlo cudno, ali ti, ocigledno, nemas yum instaliran.... Moraces da ga instaliras na ruke, ako zelis da ga koristis. Znaci, skines yum rpm i sta njemu treba. Isto smorno kao da skidas gcc i sta njemu treba, samo sto ovo radis jednom , a na dalje radi yum. Ne gine ti malo rada na ruke, dok pobegnes iz (dependency) pakla.
[ Napushenko @ 17.07.2008. 18:21 ] @
Ev probo sam i sa yum-om al ni sa tim srece.

Code:

[[email protected] yum]# rpm -ihv yum-2.4.3-4.el4.centos.noarch.rpm
warning: yum-2.4.3-4.el4.centos.noarch.rpm: V3 DSA signature: NOKEY, key ID 443e1821
error: Failed dependencies:
        python-sqlite is needed by yum-2.4.3-4.el4.centos.noarch
        yum-metadata-parser is needed by yum-2.4.3-4.el4.centos.noarch
[[email protected] yum]# rpm -ihv python-sqlite-1.1.7-1.2.1.i386.rpm
warning: python-sqlite-1.1.7-1.2.1.i386.rpm: V3 DSA signature: NOKEY, key ID 443e1821
error: Failed dependencies:
        libsqlite3.so.0 is needed by python-sqlite-1.1.7-1.2.1.i386
[[email protected] yum]# rpm -ihv yum-metadata-parser-1.0-8.el4.centos.i386.rpm
warning: yum-metadata-parser-1.0-8.el4.centos.i386.rpm: V3 DSA signature: NOKEY, key ID 443e1821
error: Failed dependencies:
        libsqlite3.so.0 is needed by yum-metadata-parser-1.0-8.el4.centos.i386
[[email protected] yum]#


A ovaj libsqlite3.so.0 paket uopste ne postoji.
Neam pojma u cemu je problem,trebam se javit podrsci dzaba ode 50 eura.
[ freelancer @ 17.07.2008. 20:26 ] @
Yum paket koji si nabavio ipak ne odgovara tvom sistemu. Prema informacijama koje si poslao u prvoj poruci operativni sistem je CentOS 4.2. Pokusaj da odgovarajuci yum paket pronadjes na vault.centos.org. Mozda ces morati da upotrebis argument --force sa rpm-om kako bi uspeo da instaliras paket. Oprez prilikom koriscenja ovog argumenta se podrazumeva. Takodje trebas obratiti paznju na zavisnosti medju paketima, ovaj clanak ti moze pomoci: http://www.cyberciti.biz/faq/h...t-dependencies-a-rpm-file-has/.
[ nkrgovic @ 17.07.2008. 23:41 ] @
Ne postoji libsqlite paket, ali postoji sqlite paket. Instaliras njega. Objasnjenje : sqlite je biblioteka, da ne kazem lib :D. Znaci, samo instaliraj sqlite 3 i to je to.