[ marcor @ 11.04.2009. 13:48 ] @

Pozdrav. Imam sledeci problem, problem me muci odkad sam naucio da napravim flash preloader sa AS2. Naime, rec je o tome da bilo gde da stavim preloader (na sajt, animaciju, ili bilo sta drugo) desava mi se da po pokretanju swf fajla, moram da sacekam par sec pa mi se tek onda pojavi preloader, koji nastavi sa ucitavanjem negde od polovine. To i nije bilo toliko strasno, preloader se bar pojavljivao. Sad imam sl. problem. Radim cd prezentaciju koja ce ujedno ici i na web. Postavio sam preloader na prvom frame-u, sadrzaj na 10. Kada exportujem fla, preloader se ne pojavljuje (sto je i logicno) vec odmah pusti animaciju. E, kad pokusam sa opcijom Simulate Download, pojavi mi se crna pozadina i onda cekam nekih 20-tak sec i nakon toga mi pusti animaciju, preloader se pojavljuje na kratko nakon tih 20-tak sec.

Pokusao sam sa opcijom Bandwidth profiler i za svo to vreme vidim da se animacija ucitava (naravno to vidim u Bandwidth profiler-u) a background je opet crn. Tek kad na Bandwidth profiler-u bude "Loaded: 100%", na kratko mi pojavi preloader i pocne sa animacijom.

Pokusao sam sa drugim kodom, cak sam skidao i gotove preloadere i opet istva stvar.

Molim za pomoc, jer mi je stvarno hitno...

Cackao sam i nasao problem, problem je u tome sto postoji mnogo zvukova u library koji su exportovani u prvom frejmu. Sad mi je jasna stvar sa preloaderom, e sam mi je potrebna pomoc, kako to resiti. Imati preloader i linkovati sound iz biblioteke u nekom drugom frejmu, a ne u prvom? Da li je to moguce?

[Ovu poruku je menjao marcor dana 11.04.2009. u 15:33 GMT+1]
[ StarCraft @ 12.04.2009. 14:46 ] @
Vidim da si reŇ°io problem ;)