[ nin0 @ 23.09.2009. 21:54 ] @
Danima vec pokusavam da osposobim ovaj rt61 legacy driver i nikako mi ne uspeva.Instaliram sve po propisu, bleklistujem stari rt61pci i nakon restarta ne mogu da uspostavim konekciju. Inace kartica je D-Link DWL-G510 a legacy driver sam skinuo sa http://rt2x00.serialmonkey.com/wiki/index.php/Downloads
Instalirao sam i Rtutilt-alatka koja ima istu svrhu kao i network manager. Sve ovo pokusavam na Linux Mint 7 a konektujem se na wireless router sa wep sifrom. Ne samo sto nemogu da se konektujem vec i nemam info o jacini signala za bilo koji router sa wep/wpa/wpa2 enkripcijom.Evo sta sam redom odradio prilikom instalacije:

1. sudo killall NetworkManager

2. sudo rmmod rt61pci rt2x00pci rt2x00lib

3. sudo gedit /etc/modprobe.d/blacklist # i dodam
blacklist rt61pci
blacklist rt2x00pci
blacklist rt2x00lib

4. instalacija legacy drivera
tar zxvf rt2500-cvs-2009041204.tar.gz
cd rt61-cvs*/Module
sudo make
sudo make install

5. modprobe rt61

6. sudo gedit /etc/modules # tu na kraju dodam rt61

7. Restart

Ovaj driver mi treba jer ima naprednije funkcije od ovog sto ide uz sistem (postavljanje u master, AP, monitor mod, info o noise level...)
Nadam se neko ima iskustva s ovim driverom ili zna kako da sve ovo dovedem u red.Prevrnuo sam brdo sajtova na ovu temu al nista dok se ne prozbori na srpskom
[ combuster @ 23.09.2009. 22:11 ] @
Prvo sto mi pade na pamet, jel imas wpa_supplicant?

http://hostap.epitest.fi/wpa_supplicant/

Ako nemas instaliraj ga, trebalo bi da ti resi probleme sa konektovanjem na wpa/wep zasticene mreze...
[ nin0 @ 24.09.2009. 18:43 ] @
Instaliran je wpasupplicant, ima ga u synaptiku.Imas li ideju sta dalje?
[ combuster @ 24.09.2009. 19:50 ] @
Osim da je problem u drajveru - ne...

Bas se radilo cini mi se na ovom drajveru u kernelu ovih dana pa bi ti mozda bolje bilo da isprobas najnoviji ubuntu 9.10 iako je alpha i da vidis kako se ponasa... Sa live-a nece da skodi...
[ nin0 @ 24.09.2009. 20:42 ] @
bas cu da skinem ubuntu da vidim sta ce reci. Ovo je super ako stave rt61 driver u ubuntu 9.10.
[ Srđan Pavlović @ 25.09.2009. 09:14 ] @
[email protected]:~$ locate rt61
/lib/modules/2.6.31-10-generic/kernel/drivers/net/wireless/rt2x00/rt61pci.ko
/usr/src/linux-headers-2.6.31-10-generic/include/config/rt61pci.h
[email protected]:~$ uname -a
Linux Zverko 2.6.31-10-generic #35-Ubuntu SMP Tue Sep 22 17:33:14 UTC 2009 x86_64 GNU/Linux
[email protected]:~$

(Ubuntu 9.10)
[ nin0 @ 25.09.2009. 11:02 ] @
Ako sam dobro razumeo i u 9.10 je ista situacija-i dalje rt61pci.
A sad nazad na stare muke...

evo sta dobijam na komandu "locate rt61"

/lib/modules/2.6.28-15-generic/kernel/drivers/net/wireless/rt61.ko
/lib/modules/2.6.28-15-generic/kernel/drivers/net/wireless/rt2x00/rt61pci.ko
/lib/modules/2.6.28.10/extra/rt61.ko
/usr/src/linux-headers-2.6.28-11-generic/include/config/rt61pci.h
/usr/src/linux-headers-2.6.28-15-generic/include/config/rt61pci.h

Pri tome mi je aktivan rt61pci.
[ combuster @ 25.09.2009. 15:15 ] @
Misilo sam da su radili dosta na rt61pci a ne da ce rt61 uci u kernel :)
[ nin0 @ 25.09.2009. 18:29 ] @
Znaci li to da bi ubacivanjem novog kernela u mintu i drajver radio bolje.Karmik dolazi sa 2.6.30 ako se ne varam.
[ combuster @ 25.09.2009. 20:06 ] @
2.6.31 Karmic, vidis iz Srdjanovog post-a... Nemam pojma, ne kosta te nista da skines 700 MB ako imas broadband konekciju i da isprobas preko live-a...
[ nin0 @ 25.09.2009. 20:40 ] @
Upravo sam pobao da butujem karmic i to bezuspesno! probao sam i sa fleske i sa rw-a.Ukoci se na boot screen-u. Ili se iso lose skinuo ili ova alfa jednostavno ne pasuje kod mene.Maler!
[ Srđan Pavlović @ 25.09.2009. 23:30 ] @
Probaj butovati sa opcijom acpi=off

Alfa 6 se kod mene butuje normalno i na laptopu i
na desktopu... proveri md5 sum, tj. da li je ISO dobro
skinut, za svaki slucaj.
[ nin0 @ 26.09.2009. 10:52 ] @
Ipak je bug.MD5 je dobar, uradio sam acpi off pri butvalnju ali nije pomoglo dobijem neke silne konflikte i trazi mi da apdejtujem bios (malo ce da me sacekaju za to)
zapamtio sam ovo
unknown key SYMLINK{unique} in /lib/udev/rules.d/50-udev-default.rules:4

Ovde kazu da je stvar resena...malo sutra.

Ostaje mi samo da sacekam betu sledece nedelje. Odvede me ovaj suntavi driver na savim 17-tu stranu.
[ combuster @ 26.09.2009. 10:53 ] @
hahahaha, pa tako ti je to uvek, krenes da resavas jedno a na kraju resavas 5 drugih razlicitih problema :)
[ nin0 @ 26.09.2009. 11:05 ] @
Na kraju ce jos da mi trazi da ocistim komsijin WC da bi se butovao
[ Srđan Pavlović @ 26.09.2009. 15:03 ] @
To sa udevom je ispravljeno, kad apdejtujes Alfa 6 toga vise nema (tih poruka).
Mada vidis, kod mene na oba kompa i pored tih poruka, sistem se podigne dalje OK,
bas sam i na desktop i na laptop instalirao sa Alfa6 ISO-a.

Brzo ce to sve biti ispravljeno, sacekaj sledecu dev verziju pa skini
(BETU).

Citat:
Na kraju ce jos da mi trazi da ocistim komsijin WC da bi se butovao

Pa sistem je u Alfa fazi tek, cisti se od bagova, naravno da ih sada ima dosta.
[ nin0 @ 26.09.2009. 15:46 ] @
Naravno,potpuno se slazem. Ne moze se prvise ocekivati od razvojne verzije. Vremenom ce sve da se sredi.