[ gossa @ 23.04.2011. 12:25 ] @


Imam mali problem , pre par dana u firmi su resili da zamene analogne linije i uzmu Telekomov VoIP BizTrunk , dobio sam parametre od Telekoma , sa onoliko malo znanja koje imam, podesio sam i uspeo sam da napravim OUTGOING poziv ali imam problem sa dolaznim INCOMING pozivima , nikako ne uspevam da ih izrutiram , ideja je da svaka od 15 numeracija zvoni na odgovarajuci lokal i da svaki odlazni poziv sa odgovarajuceg lokala ima odgovarajuci odlazni Caler ID tj da se ne pojavljuje vodeci broj kao indetifikacija . Od opreme koristi se Cisco ISR 2901 sa CME 8.5 i gomila telefona 7945. Unutrasnja numeracija lokala ide od 100 do 115 to su SCCP 7945 i od 200 do 215 za sof telefone sa SIP protokolom tj IP Comunicatorm. Numeracija od Telekoma ide ABCDEFGH0000 do ABCDEFGH0015 . ABCDEFGH0000 je noseci ili PBX broj

evo malog izvoda konfiguracije

ip domain name ims.telekomsrbija.com
ip host ims.telekomsrbija.com 10.0.0.2

voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol pass-through g711alaw
h323
sip
registrar server

voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw


voice translation-rule 1
rule 1 /^.*/ /ABCDEFGH0000/

voice translation-profile SIP-OUTGOING
translate calling 1

Setovo sam razne Dial-peer eve zbog restrikcije odlaznih poziva recimo ovaj je za poziv upucen ka mobiloj mrezi

dial-peer voice 1004 voip
corlist outgoing POZIVmobilni
translation-profile outgoing SIP-OUTGOING
destination-pattern 06T
session protocol sipv2
session target dns:ims.telekomsrbija.com
dtmf-relay sip-notify rtp-nte
codec g711alaw


Ovim peer-om sam hteo da mi zazvoni soft lokal 207 ako se zove spoljni broj ABCDEFGH0007
dial-peer voice 5000 voip
description BIZ TRUNK INCOMING
session protocol sipv2
session target sip-server
incoming called-number ABCDEFGH0007
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
answer-address 207

Ovo je deo registracije SIP trunka

sip-ua
credentials number ABCDEFGH0000 username [email protected] password 7 xxxxxxxxxxxx realm ims.telekomsrbija.com
registrar dns:ims.telekomsrbija.com expires 3600
sip-server ipv4:10.0.0.2:5060





Please help,
[ Ve$eli @ 23.04.2011. 21:23 ] @
http://www.cisco.com/en/US/tec...ech_note09186a0080325e8e.shtml
+ answer-address komanda ne sluzi da bi ti 207 ephone-dn odgovorio na poziv, vec samo za matchovanje dial-peer-a i to ne za DNIS nego za ANI.
Tako da ti je za incoming pozive potrebno samo da nastimas da ti se vrsi tranformacija dolaznog broja u neki ephone-dn.
[ ares2301 @ 24.04.2011. 21:12 ] @
Za rutiranje dolaznih poziva od Telekoma potrebna ti je skripta koja ce iz SIP poruka citati TO polje i prosledjivati ka odredjenom lokalu. Naime, Telekomov IMS u TO polju SIP poruke salje broj iz tvoje numeracije na koji je upucen poziv.


###################################################
proc setup { } {
# local settings
set areaCode 5
set leadNum 66
# end local settings
leg proceeding leg_incoming
set To [infotag get leg_proto_headers "To"]
set numero $To
regexp {sip:[0-9]+([0-9]{2})@} $To w numero
set numero $areaCode$numero
if { $numero == 508 } { set numero 581 }
if { $numero == 509 } { set numero 502 }
if { $numero == 510 } { set numero 531 }
if { $numero == 511 } { set numero 541 }
if { $numero == 512 } { set numero 566 }
if { [regexp {tel:\+[0-9]+} $To telBroj] } { set numero $areaCode$leadNum }
leg setup $numero callInfo leg_incoming
}

proc setup_done { } {
# Handle SETUP DONE.
}


proc cleanup { } {
call close
}


requiredversion 2.0


#----------------------------------
# State Machine
#----------------------------------

set fsm(any_state,ev_disconnected) "cleanup same_state"
set fsm(CALL_INIT,ev_setup_indication) "setup GETDEST"
set fsm(GETDEST,ev_setup_done) "setup_done CALLACTIVE"
set fsm(CALLACTIVE,ev_disconnected) "cleanup CALLDISCONNECT"
set fsm(CALLDISCONNECT,ev_disconnected) "cleanup same_state"
set fsm(CALLDISCONNECT,ev_disconnect_done) "cleanup same_state"

fsm define fsm CALL_INIT
######################################################

Malo da objasnim skriptu. Promenljiva areaCode ti je prvi broj u tvojoj numeraciji (kod tebe je 1). Promeljiva leadNum ti je lokal na koji prosledjujes pozive na tvoj noseci broj ali bez pocetnog broja (npr ako prosledjujes na lokal 112 onda je leadNum 12). U if delu definises na koji lokal (set numero) prosledjujes pozive ka brojevima iz tvoje numeracije ($numero ==). Obrati paznju da skripta uzima dva broja iz TO polja i dodaje areaCode, tako da ces imati brojeve od 101 do 115.
Preradi skriptu prema tvojim zahtevima pa je snimi pod ekstenzijom .tcl. Prebaci je na flash pa je registruj sa

Application
service TORoute flash:TORoute.tcl

TORoute je naziv servisa (nazovi servis kako ti zelis) a TORoute.tcl je sama skripta.

Dodaj sledece

voice service voip
allow-connections sip to sip
sip
header-passing
early-offer forced
midcall-signaling passthru

dial-peer voice 5000 voip
service TOroute
incoming called-number <noseci_broj>

Sto se tice odlaznih poziva, u translation rulu dodaj

rule 1 /lokal/ /broj_iz_numeracije/
rule 2 /lokal/ /broj_iz_numeracije/
.....
rule 15 /^...$/ /381117151707/

Nadam se ce ti ovo pomoci. Javi da li si uspeo.
[ gossa @ 25.04.2011. 07:15 ] @
Probacu odmah, 100% zahvalan, da saljem jedan six-pack post expresom ?
[ ares2301 @ 25.04.2011. 19:47 ] @
Ne zezaj :)))

Bitno je da resimo problem ;)
[ gossa @ 25.04.2011. 22:29 ] @
Nece nesto
dobijam u debug-u

CALL_ERROR_INFORMATIONAL; Call Id Is Invalid=-1

Da li mogu da te zamolim da pogledash debug log da ga ne postujem ovde , cini mi se da je po debugu pogodio dial-peer, usao u application toroute ali da nije uspe da iskonvertuje TO

skript sam prilagodio ovako


###################################################
proc setup { } {
# local settings
set areaCode 1
set leadNum 00
# end local settings
leg proceeding leg_incoming
set To [infotag get leg_proto_headers "To"]
set numero $To
regexp {sip:[0-9]+([0-9]{2})@} $To w numero
set numero $areaCode$numero
if { $numero == 101 } { set numero 100 }
if { $numero == 102 } { set numero 100 }
if { $numero == 103 } { set numero 103 }
if { $numero == 104 } { set numero 104 }
if { $numero == 105 } { set numero 105 }
if { $numero == 106 } { set numero 106 }
if { $numero == 107 } { set numero 207 }

if { [regexp {tel:\+[0-9]+} $To telBroj] } { set numero $areaCode$leadNum }
leg setup $numero callInfo leg_incoming
puts "\n >>>>> TCL-SCRIPT Translate: To = $To ; numero = $numero \n"
}

proc setup_done { } {
# Handle SETUP DONE.
}


......

Imate li ideju sta moze biti ? ;(



Please skini log sa http://www.megaupload.com/?d=7MLHIAL2 neynam kako da atachujem fajl u conf

[ ares2301 @ 26.04.2011. 07:14 ] @
Molim te, posalji mi debug (debug ccsip messages) i deo konfiguracije (kao prvi post).
[ gossa @ 26.04.2011. 09:31 ] @
EVO KONFIGURACIJE


ip domain name ims.telekomsrbija.com
ip host ims.telekomsrbija.com 10.0.0.2
!
multilink bundle-name authenticated

voice-card 0
!
!
!
voice service voip
allow-connections h323 to h323
allow-connections h323 to sip
allow-connections sip to h323
allow-connections sip to sip
fax protocol pass-through g711alaw
h323
sip
header-passing
registrar server
early-offer forced
midcall-signaling passthru
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
!
!
voice register global
mode cme
source-address 192.168.2.251 port 5060
max-dn 6
max-pool 6
authenticate register
tftp-path flash:
create profile sync 0131511014412104
!
!
!
voice translation-rule 1
rule 1 /100/ /ABCDEFGH0000/
rule 2 /101/ /ABCDEFGH0001/
rule 3 /102/ /ABCDEFGH0002/
rule 4 /103/ /ABCDEFGH0003/
rule 5 /104/ /ABCDEFGH0004/
rule 6 /105/ /ABCDEFGH0005/
rule 7 /106/ /ABCDEFGH0006/
rule 8 /207/ /ABCDEFGH0007/
rule 15 /^...$/ /ABCDEFGH0000/
!
voice translation-profile SIP-OUTGOING
translate calling 1
!
!
!
application
service toroute flash:toroute.tcl
!
!
hw-module ism 0
!
hw-module pvdm 0/0
!
!
!
dial-control-mib retain-timer 35000
dial-control-mib max-size 1200[!
redundancy
!
!
!
!
!
class-map match-all L3-to-L2_VoIP-Cntrl
match ip dscp af31
class-map match-all L3-to-L2_VoIP-RTP
match ip dscp ef
class-map match-all SIP
match protocol sip
class-map match-all RTP
match protocol rtp
!
!
policy-map EthOut
class RTP
policy-map output-L3-to-L2
class L3-to-L2_VoIP-RTP
set cos 5
class L3-to-L2_VoIP-Cntrl
set cos 3
!
!
interface GigabitEthernet0/0.2
description LAN DAT
encapsulation dot1Q 2
ip address 192.168.2.251 255.255.255.0
!
interface GigabitEthernet0/0.5
description LAN VOICE
encapsulation dot1Q 5
ip address 192.168.5.251 255.255.255.0
service-policy output output-L3-to-L2
!
interface ISM0/0
ip unnumbered GigabitEthernet0/0.2
service-module ip address 192.168.2.252 255.255.255.0
!Application: SRSV-CUE Running on ISM
service-module ip default-gateway 192.168.2.251
!
!
interface GigabitEthernet0/1.2655
description INTERFACE KA TELEKOMU VOICETRUNK
encapsulation dot1Q 2655
ip address 10.1.4.78 255.255.255.252
!
interface ISM0/1
description Internal switch interface connected to Internal Service Module
!
interface Vlan1
no ip address
!
ip forward-protocol nd
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip http path flash:/gui
!
ip route 10.0.0.1 255.255.255.255 10.1.4.77
ip route 10.0.0.2 255.255.255.255 10.1.4.77
ip route 192.168.2.252 255.255.255.255 ISM0/0
!
access-list 23 permit 192.168.2.0 0.0.0.255
!
!
tftp-server flash:SEP20CF301A7A36.cnf.xml
!
control-plane
!
!
voice-port 0/0/0
connection plar opx 100
caller-id enable
!
voice-port 0/0/1
connection plar opx 100
caller-id enable
!
voice-port 0/0/2
connection plar opx 100
caller-id enable
!
voice-port 0/0/3
connection plar opx 100
caller-id enable
!
voice-port 0/1/0
caller-id enable
!
voice-port 0/1/1
caller-id enable
!
voice-port 0/1/2
caller-id enable
!
voice-port 0/1/3
caller-id enable
!
!
!
mgcp profile default
!
!
dial-peer cor custom
name medjunarodni
name mobilni
name fiksni
name lokalni
name besplatni
name igrenasrecu
name sanaplatom
name hitnesluzbe
name servisnesluzbe
!
!
dial-peer cor list POZIVmedjunarodni
member medjunarodni
!
dial-peer cor list POZIVmobilni
member mobilni
!
dial-peer cor list POZIVfiksni
member fiksni
!
dial-peer cor list POZIVlokalni
member lokalni
!
dial-peer cor list POZIVbesplatni
member besplatni
!
dial-peer cor list POZIVsanaplatom
member sanaplatom
!
dial-peer cor list POZIVigrenasrecu
member igrenasrecu
!
dial-peer cor list POZIVhitnesluzbe
member hitnesluzbe
!
dial-peer cor list POZIVservisnesluzbe
member servisnesluzbe
!
dial-peer cor list listSVE
member medjunarodni
member mobilni
member fiksni
member lokalni
member besplatni
member igrenasrecu
member sanaplatom
member hitnesluzbe
member servisnesluzbe
!
dial-peer cor list SrbijaMobil
member mobilni
member fiksni
member lokalni
member besplatni
member hitnesluzbe
member servisnesluzbe
!
dial-peer cor list SrbijaFiksni
member fiksni
member lokalni
member besplatni
member hitnesluzbe
!
!
dial-peer voice 211 pots
destination-pattern 211
port 0/1/0
!
dial-peer voice 212 pots
destination-pattern 212
port 0/1/1
!
dial-peer voice 213 pots
destination-pattern 213
port 0/1/2
!
dial-peer voice 214 pots
destination-pattern 214
port 0/1/3
!
dial-peer voice 555 voip
description ** Exchange Unified Messaging **
destination-pattern 555
session protocol sipv2
session target ipv4:192.168.2.203
session transport tcp
dtmf-relay rtp-nte
codec g711ulaw
fax rate disable
fax protocol pass-through g711ulaw
no vad
!
dial-peer voice 5000 voip
service toroute
session protocol sipv2
session target sip-server
incoming called-number ABCDEFGH0000
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
!
dial-peer voice 1001 voip
corlist outgoing POZIVmedjunarodni
translation-profile outgoing SIP-OUTGOING
destination-pattern 00T
session protocol sipv2
session target dns:ims.telekomsrbija.com
dtmf-relay sip-notify rtp-nte
codec g711alaw
!
dial-peer voice 1002 voip
corlist outgoing POZIVfiksni
translation-profile outgoing SIP-OUTGOING
destination-pattern 0[1-3]T
session protocol sipv2
session target dns:ims.telekomsrbija.com
dtmf-relay sip-notify rtp-nte
codec g711alaw
!
dial-peer voice 1003 voip
corlist outgoing POZIVigrenasrecu
translation-profile outgoing SIP-OUTGOING
destination-pattern 0[4-5]T
session protocol sipv2
session target dns:ims.telekomsrbija.com
dtmf-relay sip-notify rtp-nte
codec g711alaw
!
dial-peer voice 1004 voip
corlist outgoing POZIVmobilni
translation-profile outgoing SIP-OUTGOING
destination-pattern 06T
session protocol sipv2
session target dns:ims.telekomsrbija.com
dtmf-relay sip-notify rtp-nte
codec g711alaw
!
dial-peer voice 1005 voip
corlist outgoing POZIVsanaplatom
translation-profile outgoing SIP-OUTGOING
destination-pattern 0[79]T
session protocol sipv2
session target dns:ims.telekomsrbija.com
dtmf-relay sip-notify rtp-nte
codec g711alaw
!
dial-peer voice 1006 voip
corlist outgoing POZIVbesplatni
translation-profile outgoing SIP-OUTGOING
destination-pattern 0[8]T
session protocol sipv2
session target dns:ims.telekomsrbija.com
dtmf-relay sip-notify rtp-nte
codec g711alaw
!
dial-peer voice 1007 voip
corlist outgoing POZIVlokalni
translation-profile outgoing SIP-OUTGOING
destination-pattern [1-8]T
session protocol sipv2
session target dns:ims.telekomsrbija.com
dtmf-relay sip-notify rtp-nte
codec g711alaw
!
dial-peer voice 1008 voip
corlist outgoing POZIVhitnesluzbe
translation-profile outgoing SIP-OUTGOING
destination-pattern 9[2-4]T
session protocol sipv2
session target dns:ims.telekomsrbija.com
dtmf-relay sip-notify rtp-nte
codec g711alaw
!
dial-peer voice 1009 voip
corlist outgoing POZIVservisnesluzbe
translation-profile outgoing SIP-OUTGOING
destination-pattern 9[5-8]T
session protocol sipv2
session target dns:ims.telekomsrbija.com
dtmf-relay sip-notify rtp-nte
codec g711alaw
!
!
sip-ua
credentials number ABCDEFGH0000 username [email protected] password 7 xxxxxxxxxxx realm ims.telekomsrbija.com
mwi-server ipv4:192.168.2.203 expires 3600 port 5060 transport tcp unsolicited
registrar dns:ims.telekomsrbija.com expires 3600
sip-server ipv4:10.0.0.2:5060
host-registrar
refer-ood enable
handle-replaces
!
!
!
gatekeeper
shutdown
!
!
telephony-service
no auto-reg-ephone
max-ephones 24
max-dn 72
ip source-address 192.168.5.251 port 2000
calling-number initiator
service phone videoCapability 1
timeouts interdigit 2
timeouts busy 5
cnf-file location flash:
time-zone 26
time-format 24
date-format dd-mm-yy
voicemail 555
mwi relay
max-conferences 8 gain -6
call-forward pattern .T
call-forward system redirecting-expanded
moh music-on-hold.au
dn-webedit
time-webedit
transfer-system full-consult dss
create cnf-files version-stamp Jan 01 2002 00:00:00
!
!




EVO DEBUG POZIVA


*Apr 26 08:16:38.435: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
INVITE sip:[email protected]:5060 SIP/2.0
Via: SIP/2.0/UDP 10.0.0.2:5060;branch=z9hG4bK0e9uml300ohhjfcm35c1.1
To: "381264150007 381264150007"<sip:[email protected]>;cscf
From: <sip:[email protected];user=phone>;tag=1693891817-1303805764393-
Call-ID: [email protected]
CSeq: 141595029 INVITE
Max-Forwards: 7
Content-Length: 248
Contact: <sip:[email protected]:5060;transport=udp>
Content-Type: application/sdp
Allow: ACK, BYE, CANCEL, INFO, INVITE, OPTIONS, PRACK, REFER, NOTIFY, UPDATE
Accept: multipart/mixed
Accept: application/media_control+xml
Accept: application/sdp
Accept: application/x-hotsip-FileTransfer+xml
Supported: 100rel, timer
P-Asserted-Identity: <sip:[email protected]>
Privacy: none
P-Charging-Vector: icid-value=6c01d7400714bd009c9d49fe5f61f9
Min-SE: 180
Session-Expires: 1800
P-Called-Party-ID: <sip:[email protected]>

v=0
o=BroadWorks 70918741 1 IN IP4 10.0.0.2
s=-
c=IN IP4 10.0.0.2
t=0 0
m=audio 37286 RTP/AVP 8 18 13 98
a=rtpmap:8 PCMA/8000
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:13 CN/8000
a=rtpmap:98 telephone-event/8000
a=fmtp:98 0-15

*Apr 26 08:16:38.451: //41896/57CF5CC5995F/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 100 Trying
Via: SIP/2.0/UDP 10.0.0.2:5060;branch=z9hG4bK0e9uml300ohhjfcm35c1.1
From: <sip:[email protected];user=phone>;tag=1693891817-1303805764393-
To: "381264150007 381264150007"<sip:[email protected]>;cscf
Date: Tue, 26 Apr 2011 08:16:38 GMT
Call-ID: [email protected]
CSeq: 141595029 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Content-Length: 0


*Apr 26 08:16:38.455: //41896/57CF5CC5995F/SIP/Msg/ccsipDisplayMsg:
Sent:
SIP/2.0 403 Forbidden
Via: SIP/2.0/UDP 10.0.0.2:5060;branch=z9hG4bK0e9uml300ohhjfcm35c1.1
From: <sip:[email protected];user=phone>;tag=1693891817-1303805764393-
To: "381264150007 381264150007"<sip:[email protected]>;cscf;tag=1201F3BC-180C
Date: Tue, 26 Apr 2011 08:16:38 GMT
Call-ID: [email protected]
CSeq: 141595029 INVITE
Allow-Events: telephone-event
Server: Cisco-SIPGateway/IOS-12.x
Reason: Q.850;cause=21
Content-Length: 0


*Apr 26 08:16:38.459: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Received:
ACK sip:[email protected]:5060 SIP/2.0
Via: SIP/2.0/UDP 10.0.0.2:5060;branch=z9hG4bK0e9uml300ohhjfcm35c1.1
CSeq: 141595029 ACK
To: "381264150007 381264150007"<sip:[email protected]>;cscf;tag=1201F3BC-180C
From: <sip:[email protected];user=phone>;tag=1693891817-1303805764393-
Call-ID: [email protected]
Max-Forwards: 7
Content-Length: 0


*Apr 26 08:16:55.915: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
REGISTER sip:ims.telekomsrbija.com:5060 SIP/2.0
Via: SIP/2.0/UDP 10.1.4.78:5060;branch=z9hG4bK85822E1
From: <sip:[email protected]>;tag=120237F4-4C2
To: <sip:[email protected]>
Date: Tue, 26 Apr 2011 08:16:55 GMT
Call-ID: 37EE00AF-6C5511E0-800E9017-67376A53
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
Timestamp: 1303805815
CSeq: 1679 REGISTER
Contact: <sip:[email protected]:5060>
Expires: 3600
Supported: path
Content-Length: 0


*Apr 26 08:16:55.931: //41900/000000000000/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 403 Forbidden
Via: SIP/2.0/UDP 10.1.4.78:5060;branch=z9hG4bK85822E1
From: <sip:[email protected]>;tag=120237F4-4C2
To: <sip:[email protected]>;tag=9f6678ee0731bac09c9d4a42e5c7eb
Call-ID: 37EE00AF-6C5511E0-800E9017-67376A53
Timestamp: 1303805815
CSeq: 1679 REGISTER
Content-Length: 0
P-Charging-Vector: icid-value=9f6678ee0731bac09c9d4a42e17e99


*Apr 26 08:17:00.803: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
REGISTER sip:ims.telekomsrbija.com:5060 SIP/2.0
Via: SIP/2.0/UDP 10.1.4.78:5060;branch=z9hG4bK85838AE
From: <sip:[email protected]>;tag=12024B0C-21B3
To: <sip:[email protected]>
Date: Tue, 26 Apr 2011 08:17:00 GMT
Call-ID: 3A10E183-6C5511E0-80169017-67376A53
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
Timestamp: 1303805820
CSeq: 1679 REGISTER
Contact: <sip:[email protected]:5060>
Expires: 3600
Supported: path
Content-Length: 0


*Apr 26 08:17:00.807: //-1/xxxxxxxxxxxx/SIP/Msg/ccsipDisplayMsg:
Sent:
REGISTER sip:ims.telekomsrbija.com:5060 SIP/2.0
Via: SIP/2.0/UDP 10.1.4.78:5060;branch=z9hG4bK85841E37
From: <sip:[email protected]>;tag=12024B0C-16E8
To: <sip:[email protected]>
Date: Tue, 26 Apr 2011 08:17:00 GMT
Call-ID: 3827FDE1-6C5511E0-80119017-67376A53
User-Agent: Cisco-SIPGateway/IOS-12.x
Max-Forwards: 70
Timestamp: 1303805820
CSeq: 1679 REGISTER
Contact: <sip:[email protected]:5060>
Expires: 3600
Supported: path
Content-Length: 0


*Apr 26 08:17:00.819: //41901/000000000000/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 403 Forbidden
Via: SIP/2.0/UDP 10.1.4.78:5060;branch=z9hG4bK85838AE
From: <sip:[email protected]>;tag=12024B0C-21B3
To: <sip:[email protected]>;tag=e76a676507cd19909c9d4a5608145f
Call-ID: 3A10E183-6C5511E0-80169017-67376A53
Timestamp: 1303805820
CSeq: 1679 REGISTER
Content-Length: 0
P-Charging-Vector: icid-value=e76a676507cd19909c9d4a560400ef


*Apr 26 08:17:00.823: //41902/000000000000/SIP/Msg/ccsipDisplayMsg:
Received:
SIP/2.0 403 Forbidden
Via: SIP/2.0/UDP 10.1.4.78:5060;branch=z9hG4bK85841E37
From: <sip:[email protected]>;tag=12024B0C-16E8
To: <sip:[email protected]>;tag=400ede05078e52e09c9d4a5604f805
Call-ID: 3827FDE1-6C5511E0-80119017-67376A53
Timestamp: 1303805820
CSeq: 1679 REGISTER
Content-Length: 0
P-Charging-Vector: icid-value=400ede05078e52e09c9d4a5600bb9e



[ ares2301 @ 26.04.2011. 19:28 ] @
Izvini sto kasnim sa odgovorom.
Vidim da koristis ruter i kao SIP server i kao SIP klijent. Mozda gresim, mislim da ne moze da bude i klijent i server. Ja sam, barem, imao problema sa tim i nisam uspeo da podesim.

Predlozio bih ti sledece. Prvo pokusaj da napravis jedan translation rule

voice translation-rule 8
rule 1 /ABCDEFGH0000/ /neki_lokal/

voice translation-profile IN_CALL
translate called 8

obrisi service toroute sa dial-peer voice 5000
i stavi samo

translation-profile incoming IN_CALL

pa probaj

Drugo, dodaj

voice service voip
ip address trusted list
ipv4 0.0.0.0 0.0.0.0

Ako ti to ne uspe, probaj da ugasis SIP server na ruteru pa pokusaj.

Ovo je deo moje konfiguracije koja radi


voice service voip
ip address trusted list
ipv4 0.0.0.0 0.0.0.0
allow-connections sip to sip
supplementary-service h450.12
no supplementary-service sip moved-temporarily
no supplementary-service sip refer
sip
header-passing
registrar server expires max 3600 min 3600
outbound-proxy ipv4:10.0.0.2:5060
no update-callerid
early-offer forced
midcall-signaling passthru
sip-profiles 1000

voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
codec preference 4 g729br8
codec preference 5 g723ar53
codec preference 6 g723ar63
codec preference 7 g723r53
codec preference 8 g723r63

voice class sip-profiles 13
request ACK sdp-header Audio-Attribute modify "recvonly" "sendrecv"
response 200 sdp-header Audio-Attribute modify "recvonly" "sendrecv"
request REINVITE sdp-header Audio-Attribute modify "inactive" "sendonly"

voice class sip-profiles 1000
request ANY sdp-header Connection-Info remove
response ANY sdp-header Connection-Info remove

voice translation-rule 707
rule 1 /611/ /ABCDEFGH0000/
rule 2 /612/ /ABCDEFGH0008/

voice translation-profile OUT_IMS
translate calling 707
translate called 1112

application
service TORoute5 flash:TORoute5.tcl

dial-peer voice 1020 voip
corlist outgoing call-local
description **CCA*OUT*OUT**
translation-profile outgoing OUT_IMS
destination-pattern 9.T
session protocol sipv2
session target sip-server
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad

dial-peer voice 3004 voip
description IN
service toroute5
session protocol sipv2
session target sip-server
incoming called-number ABCDEFGH0000
voice-class codec 1
voice-class sip dtmf-relay force rtp-nte
voice-class sip profiles 13
dtmf-relay rtp-nte
ip qos dscp cs5 media
ip qos dscp cs4 signaling
no vad

no dial-peer outbound status-check pots
sip-ua
credentials number ABCDEFGH0000 username [email protected] password 7 abcdefghij realm ims.telekomsrbija.com
no remote-party-id
retry invite 2
retry register 10
timers connect 100
registrar dns:ims.telekomsrbija.com expires 3600
sip-server ipv4:10.0.0.2:5060
host-registrar

Nadam se da ce ti ovo pomoci.