[ kozla13 @ 08.05.2011. 20:13 ] @
Zdravo ljudi,
treba mi pomoc oko instalacije program sa ovog linka

http://code.google.com/p/flowd/

inace sam pocetnik za linux
hvala puno


ako nekom uspije instalirat da mi objasni u cemu je caka (vec sam prohobavao instalirat al nije islo )
[ combuster @ 08.05.2011. 20:25 ] @
A za koju distribuciju (i koju verziju) ?
[ kozla13 @ 08.05.2011. 21:35 ] @
Prvo sam prohobao na Ubunut, pa onda sam na OpenBSD(medutim nije bilo grafickog okruzenj), pa na Fedora Core 2 i tu sam odusto
pise da podrzava sljedece paltforme
Platform Status Testing Notes
----------------------------------------------------------------------
Debian (unstable) OK some [1]
Fedora Core 2 OK well-tested [1]
OpenBSD 3.5+ OK well-tested
Redhat 9 OK tested [1] [2]
Redhat 7.3 OK in production [1] [2] [4]
Solaris 9 OK tested [1] [3]
FreeBSD Reportedly OK probably [1]

Notes:
------
[ kozla13 @ 08.05.2011. 21:37 ] @
Inace u Ubunut 11.04 samo dosao do linije 41 u ovom upustvu za instalaciju

http://code.google.com/p/flowd/source/browse/INSTALL
[ combuster @ 08.05.2011. 22:15 ] @
A sto ne probas da instaliras fprobe (imas ga u repoima za Ubuntu 11.04). FlowD je mator ko grcka i crci ces dok ne zadovoljis dep-ove (samo python moduli ako nista drugo su verovatno nekompatibilni sa novijim python-om).

Jel ti ovako nesto treba ?

http://fixx.co.za/?p=16
[ kozla13 @ 09.05.2011. 00:48 ] @
Problem je sto sam to dobio kao zadatak za seminarski, koji ne mogu da promijenim :(
[ Miroslav Strugarevic @ 09.05.2011. 00:55 ] @
Daj nam gresku koju dobijes prilikom instalacije!
[ kozla13 @ 09.05.2011. 11:06 ] @
E ovako:
kad kucam ovu naredbu

[email protected]:/home/kozla13/Desktop/flowd-0.9.1# python setup.py build
running build
running build_ext
building 'flowd' extension
creating build
creating build/temp.linux-i686-2.7
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -DPROGVER="0.9.1" -I/usr/include/python2.7 -c flowd_python.c -o build/temp.linux-i686-2.7/flowd_python.o
flowd_python.c:17:20: fatal error: Python.h: No such file or directory
compilation terminated.
error: command 'gcc' failed with exit status 1


a zatim ovu:
[email protected]:/home/kozla13/Desktop/flowd-0.9.1# python setup.py install
running install
running build
running build_ext
building 'flowd' extension
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -DPROGVER="0.9.1" -I/usr/include/python2.7 -c flowd_python.c -o build/temp.linux-i686-2.7/flowd_python.o
flowd_python.c:17:20: fatal error: Python.h: No such file or directory
compilation terminated.
error: command 'gcc' failed with exit status 1


istu gresku javlja i na ubuntu 10.10 veziji
[ Miroslav Strugarevic @ 09.05.2011. 12:51 ] @
Probaj ovo:

sudo apt-get install python-dev
[ kozla13 @ 09.05.2011. 16:17 ] @
nakon sto sam skino ove pakete, izlgeda da je proradilo :)

[email protected]:/home/kozla13/Desktop/flowd-0.9.1# python setup.py build
running build
running build_ext
building 'flowd' extension
gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fPIC -DPROGVER="0.9.1" -I/usr/include/python2.7 -c flowd_python.c -o build/temp.linux-i686-2.7/flowd_python.o
flowd_python.c: In function ‘flow_serialise’:
flowd_python.c:299:6: warning: pointer targets in passing argument 2 of ‘store_flow_serialise’ differ in signedness
store.h:274:5: note: expected ‘u_int8_t *’ but argument is of type ‘char *’
flowd_python.c: In function ‘flow_Flow’:
flowd_python.c:711:3: warning: pointer targets in passing argument 1 of ‘newFlowObject_from_blob’ differ in signedness
flowd_python.c:220:1: note: expected ‘u_int8_t *’ but argument is of type ‘char *’
creating build/lib.linux-i686-2.7
gcc -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-Bsymbolic-functions build/temp.linux-i686-2.7/flowd_python.o -L. -L../.. -lflowd -o build/lib.linux-i686-2.7/flowd.so
[email protected]:/home/kozla13/Desktop/flowd-0.9.1# python setup.py install
running install
running build
running build_ext
running install_lib
copying build/lib.linux-i686-2.7/flowd.so -> /usr/local/lib/python2.7/dist-packages
running install_egg_info
Writing /usr/local/lib/python2.7/dist-packages/flowd-0.9.1.egg-info



samo jos ne znam gdje da nadjem program i kako da ga pokrenem