[ xw00lf @ 02.04.2013. 14:31 ] @
znaci.. u pitanju su serveri koje institut "Mihajlo Pupin" isporucuje svojim klijentima, i na njima se izvrsavaju aplikacije koje oni komercijalno prodaju i odrzavaju..
u mom slucaju radi se o aplikaciju za vodjenje poslova Lokalne Poreske administracije pri opstinskim upravama i gradskim opstinama

da bi server ispravno radio i mogao biti odrzavan, zahtevali su obezbedjivanje staticke IP adrese... na samom serveru su u iptables zabranjene sve konekcije spolja osim od strane IP adresa iz domena instituta Mihajlo Pupin.... ja sam dodao i svoju adresu da bi mogao iz druge kancelarije preko VNC da se kacim na isti... (administriram im mrezu u lokalu i tako jos neke sitnice tu i tamo)..

SVE JE LEPO FUNKCIONISALO DOK LOKALNI PROVAJDER NIJE PROMENIO STATICKU IP ADRESU TOM SERVERU..
otkada smo rucno preko onog GUI-a uneli nove IP adrese, nastali su problemi.. Naime, u serveru je fizicki smestena 1 mrezna kartica, ali je konfigurisan tako da radi i u LAN mrezi i na internet mrezi. (eth0 i eth0:1)...

ZNACI, sve lepo radi sa novim statickim adresama, ali kada se server restartuje, inicijalizuje se samo eth0, dok eth0:1 ne radi (nece automatski da se inicijalizuje).. moram svaki put posle restarta servera da fizicki sednem za server i kliknem na "activate" u onom GUI-u (network configuration)... dok to ne uradim nema konekcija ka internetu...

KAKO DA NAMESTIM NA RHLE DA SE eth0:1 samostartuje i inicijalizuje prilikom restarta servera? napominjem da je sve radilo automatski dok nisam u GUI promenio parametre za mrezu...

citao sam po netu, proveravao i one konfiguracione fajlove za mrezu, ali ne vidim (barem ja?) nista sumnjivo....

svaka pomoc dobrodosla, hvala unapred
[ nkrgovic @ 02.04.2013. 15:11 ] @
Napravis alias u /etc/sysconfig/network-scripts/ diru. Iskopiras oanj za eth0 i samo dodas adresu, broadcast, netmask i rutu ako je razlicita.

Ugasis GUI. Server ne treba da ima podignute X-e.
[ Ned123 @ 02.04.2013. 17:44 ] @
U file /etc/sysconfig/network-scripts/ifcfg-eth0:1
dodaj:
ONBOOT=yes
[ xw00lf @ 03.04.2013. 01:17 ] @
provericu sutra ono sto ste mi sugerisali, pa cemo videti.. ako je potrebno, stavicu copy/paste tih konfiguracionih fajlova sutra pa cemo videti koja opcija je za sta odgovorna..

ukratko, po secanju, stvari stoje ovako:

ubacen je alias eth0:1 u onaj scripts folder
u tom txt fajlu se nalazi opcija onboot=yes
u pravi si za Xwin na serveru da je nepotreban visak koji trosi resurse, i da je najbolje administrirati stvari iz terminala, a resurse koje pojede xwin prepustiti bitnim servisima radi povecanja performansi... ALI JA NEMA PRAVO I NE SMEM DA RADIM TAKO DRASTICNE PROMENE, zato sto je server isporucen takav kakav je - oni ga administriraju i dopunjavaju svoju LPA aplikaciju preko interneta, koristeci VNC a samim tim i xwindows okruzenje (zato su i trazili zasticenu staticku ip adresu).. dovoljno sam modifikovao server, sto sam prckao po iptables da ubacim svoju ip adresu da bi mogao iz svoje kancelarije da pristupam tom istom VNC servisu (da ne moram svaki put da ustajem i izlazim u dvoriste u drugu zgradu).. Mislim da ako bi preterao sa modifikacijama na serveru, da bi izgubili pravo na podrsku i garanciju (koja vazi samo za stanje stvari onako kako su oni isplanirali, zamislili i isporucili)...

Jedino sto nisam nacisto je da li je kolega informaticar koji je bio lokalni administrator pre mene (otisao trbuhom za kruhom u drugi grad, na bolje placeno radno mesto) da li je sam konfigurisao virtuelni mrezni adapter eth0:1 tj. pristup internetu ili mu je neko pomogao i ko? Utoliko vise sto su ta podesavanja koja sam nasledio radila besprekorno sa starom statickom IP adresom (posle restarta se mreza inicijalizovala besprekorno i na eth0 i na eth0:1), a sad kad sam ja promenio podesavanja za staticku IP adresu, eth0:1 se ne inicijalizuje automatski nego moram rucno da ga "poteram"...

p.s.
da nije problem mozda u scipti koja inicijalizuje mrezu.. kad uradim restart network-a, one linije/izvestaji ne sadrze nista o eth0:1... pa mi je malo sumnjivo
[ Ned123 @ 03.04.2013. 04:27 ] @
Postuj ovdje output:

cat /etc/sysconfig/network-scripts/ifcfg-eth0:1

Eventualno zamaskiraj IP/MAC ako je povjerljivo.
[ xw00lf @ 03.04.2013. 10:43 ] @
evo dole potrebnih informacija... stavio sam sadrzaj svih konfiguracionih fajlova koji potpadaju pod profil "promene" a koji se koristi.. koliko vidim, kad se unesu promene u /etc/sysconfig/network-scripts/ifcfg-eth0 i eth0:1 - automatski se iste odrzavaju i na sadrzaj istoimenih fajlova u "promene" folderu.. verovatno su linkovani podaci ili kako vec, ne razumem se bas toliko......
pogledajte, pa da vidimo sta dalje

napominjem da je po default-u tamo gde pise BOOTPROTO, pisalo "none".. a ja sam prepravio u "static" po sugestiji sa jednog stranog foruma, ali opet nista - ista prica...

Citat:
[[email protected] sysconfig]$ ls network-scripts
ifcfg-eth0 ifdown-ipv6 ifup-aliases ifup-plip ifup-wireless
ifcfg-eth0:1 ifdown-isdn ifup-ib ifup-plusb init.ipv6-global
ifcfg-lo ifdown-post ifup-ippp ifup-post network-functions
ifdown ifdown-ppp ifup-ipsec ifup-ppp network-functions-ipv6
ifdown-aliases ifdown-sit ifup-ipv6 ifup-routes
ifdown-ippp ifdown-sl ifup-ipx ifup-sit
ifdown-ipsec ifup ifup-isdn ifup-sl
Petrovac na Mlavi
[[email protected] sysconfig]$ ls networking
devices profiles
Petrovac na Mlavi
[[email protected] sysconfig]$ ls networking/profiles
default promene
Petrovac na Mlavi
[[email protected] sysconfig]$ ls networking/profiles/promene
hosts ifcfg-eth0 ifcfg-eth0:1 network resolv.conf
Petrovac na Mlavi
[[email protected] sysconfig]$ ls networking/devices/
ifcfg-eth0 ifcfg-eth0:1
Petrovac na Mlavi
[[email protected] sysconfig]$
--------------------------------------------------------------------
GNU nano 1.2.4 File: hosts
192.168.0.16 centos
192.168.0.15 rhas viking
127.0.0.1 localhost.localdomain localhost
---------------------------------------------------------------------
GNU nano 1.2.4 File: ifcfg-eth0
DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.0.15
NETMASK=255.255.255.0
NETWORK=192.168.0.0
ONBOOT=yes
TYPE=Ethernet
USERCTL=yes
IPV6INIT=no
PEERDNS=yes
---------------------------------------------------------------------
GNU nano 1.2.4 File: ifcfg-eth0:1
DEVICE=eth0:1
BOOTPROTO=static
IPADDR=109.72.57.90
NETMASK=255.255.255.248
NETWORK=109.72.57.88
TYPE=Ethernet
GATEWAY=109.72.57.89
USERCTL=yes
IPV6INIT=no
ONPARENT=yes
PEERDNS=yes
ONBOOT=yes

----------------------------------------------------------------------
GNU nano 1.2.4 File: network
HOSTNAME=rhas
----------------------------------------------------------------------
GNU nano 1.2.4 File: resolv.conf
nameserver 109.72.63.1
nameserver 109.72.63.30
[ xw00lf @ 04.04.2013. 13:03 ] @
Zar niko nema ništa da doda? @[email protected]'
[ nkrgovic @ 04.04.2013. 13:31 ] @
Dodaj u sysconfig/network red:

NETWORKING=yes

[ Ned123 @ 04.04.2013. 16:31 ] @
Čak i da ONBOOT nije usable u slučaju aliasa (čini mi se da je tako), imaš ONPARENT=yes tako da bi alias morao da se diže kad i eth0.
Ono što mi još pada na pamet je da nemaš eth0:0 ? Pokušaj prepraviti alias name i device u pomenuti.
[ xw00lf @ 05.04.2013. 09:53 ] @
kako da preimenujem alias eth0:1 u eth0:0 a da nesto ne zeznem?
moze step by step uputstvo kako se to radi... razumite me :)
[ Miroslav Strugarevic @ 05.04.2013. 12:52 ] @
Moras imati "downtime" dok ovo budes radio.

Code:
cp /etc/sysconfig/network-scripts/ifcfg-eth0:1 /etc/sysconfig/network-scripts/ifcfg-eth0:0

# Proveri da li je device eth0:1 preimenovan u eth0:0
sed s/DEVICE=eth0:1/DEVICE=eth0:0/ /etc/sysconfig/network-scripts/ifcfg-eth0:0

# Ako je sve ok, onda dodaj -i da napravis trajne promene u fajlu
sed -i s/DEVICE=eth0:1/DEVICE=eth0:0/ /etc/sysconfig/network-scripts/ifcfg-eth0:0
ifdown eth0:1

# Kada napravis ifcfg-eth0:0 onda obrisi stari fajl
rm /etc/sysconfig/network-scripts/ifcfg-eth0:1

ifup eth0:0


p.s. Ako nemas razloga za rename (a verujem da nemas) onda bolje ostavi sve kako jeste :) Kozmetika nije bitna!

[Ovu poruku je menjao Miroslav Strugarevic dana 05.04.2013. u 15:49 GMT+1]