[ Milan Kragujevic @ 10.01.2020. 09:37 ] @
Nabavio sam hap ac2 i podesio WiFi kako znam.

Problem se javlja što se svaki telefon (3 komada sam probao), pri pokušaju povezivanja na 5G mrežu, restartuje.
Uključujući i telefon koji nije rutovan i kupljen juče. Android je u pitanju, i to soft-reboot (nije kernel panic već se samo zygote sruši, izvrti bootanimation, aktivira RIL (gsm pa onda wifi+bt), i ako vidi mrežu opet se restartuje, sve dok ne ugasim ruter ili promenim naziv mreže. Pre pokušaja povezivanja telefon ne pravi problem.

Laptop vidi mrežu i poveže se bez problema.

Podešavanja su:

mod: regulatory-domain
zemlja: srbija
gain: 0
freq: 5180 (ch 36)
mod: ac only
kanal: 20/40/80 Ceee

2.4G radi normalno.

Kada stavim kanal na auto, ruter skenira radar i nikad da završi, posle 10 minuta sam odustao.

ruter je nov, nekorišćen, ažuriran na poslednji stable routeros iz winbox menija.

telefoni su dva šaomi i 1 samsung

Ruter sam ugasio jer se možda komšijama restartuju telefoni, pa da ne malteretiram okolinu, a na netu nisam našao info za hap ac2 i ovakav problem.
[ Branimir Maksimovic @ 10.01.2020. 11:59 ] @
Naleteo si na neki bug u Androidu...

"Kada stavim kanal na auto, ruter skenira radar i nikad da završi,"

ionako 36-42 je safe bet da ce svi uredjaji hvatati...
[ sdurut @ 10.01.2020. 12:03 ] @
Mozda telefon i njegov kernel ima neki bug. Probaj sa konzervativnim setovanjima za ruter na 5GHz. Za početak stavi samo A standard. Posle stavi A/N standard ili only N i širinu kanala 20/40. Kad budes kasnije eksperimentisao umesto Ceee podesavanja stavi XXXX. XXXX modulacija često rešava probleme sa nekomatibilošću. Ja lično izbegavam Auto mod za frekvenciju. Nove verzije Mikrotika imaju neki problem sa radarom i skeniranjem opsega. Umesto Only AC probaj A/N/AC opciju. Mozda taj telefon ne podrzava AC u potpunosti pa se desava pucanje drivara za wifi i soft reboot-a.
[ Milan Kragujevic @ 10.01.2020. 12:13 ] @
Radi na only N modu do 150 Mbps (jedan prostorni stream na 40 MHz, telefon nema dve antene). Nisam probao AC 40 MHZ, niti A/N/AC mod.

Telefoni su Galaxy A80 (otključan bootloader, DIY AOSP instaliran), Redmi Note 8T i Redmi Note 3 (custom kernel, AOSP build from source, custom otključan bootloader i portovan RIL stack).

Ovaj u sredini je naj-merodavniji, pošto je kupljen juče, ima stock OS (Global verzija, kupljen u Srbiji) i nije otključavan. Druga dva ignorišem jer je možda sistem zeznut, ali sam radi poređenja testirao.

Probaću A/N/AC mod na 40 MHz (ne znam da li AC može na 20 MHz? kod jeftinih rutera, sve manje od 80 MHz je N, bez obzira što je stavljen AC-only režim)

edit: Note 8T podržava 5GHz, na poslu sam i kači se bez problema na Unifi AP AC Pro, oko 90 Mbps izvlači, ne znam da li je ethernet port 100 Mbps ili gigabit (pošto je na računarima 100 Mbps veza u kancelariji)
[ Zlatni_bg @ 10.01.2020. 23:43 ] @
Nemoj da forsiras AC na uredjajima preko AP-a.
[ npero @ 12.01.2020. 08:00 ] @
hAP ac2 kod mene Nokia 8.1 sa Android 10 stock OS, band a/n/ac, 80Mhz kanal, WPA/WPA2 enkripcija nikakvih problema. Podesio sam jos 4,5 komada ljudima nisam video niti cuo da se nekom resetuje telefon niti da se neko zali na to.
Sto ne izaberes superchannel i no_country_set i na taj nacin iskljucis DFS ili ti detekciju radara ima neki ralzog secifican zasto ti treba aktivan DFS ?
Upravo urajden speedtest na telefonu 88/18Mbita od mogucih 100 sa 20 na laptoopu imam punu brzinu na 5GHz upravo probao.
[ Milan Kragujevic @ 12.01.2020. 08:47 ] @


Podešavanja. Telefon se restartuje.
[ Milan Kragujevic @ 12.01.2020. 08:52 ] @
Proradilo, 5260 MHz i ništa nisam dirao.

Speedtest: https://milankragujevic.com/up...g.zwanoo.android.speedtest.jpg
[ bachi @ 12.01.2020. 09:00 ] @
Ima mnogo piglu 5GHz AC klijenata.
[ Milan Kragujevic @ 12.01.2020. 09:12 ] @
To je za sada bio domen Samsung-a, zato sam i uzeo kineza. SoC podržava do 867 Mbps, ali je konfiguracija u telefonu ipak do 433 Mbps.
[ bmarkovic06 @ 12.01.2020. 09:16 ] @
Citat:
Milan Kragujevic:
Proradilo, 5260 MHz i ništa nisam dirao.

Speedtest: https://milankragujevic.com/up...g.zwanoo.android.speedtest.jpg


Verovatno zato sto si stavio 20/40/80 XXXX, nemoj da stavljas da ti sam ruter odredjuje koji ce biti centralni a koji ekstenzioni kanal/i. Moguce je da je na 5180 odredio da je bas 5180 centrlni sa 3 ekstenziona ispod eeeC (e tu je problem).

Uvek koristi jednu freq ali stavi da ti bude npr eCee ako si barem 20mhz iznad 5180 ili Ceee ako si bas na 5180.

Takodje promeni instalation na Any ne na outdoor. Ili na indoor ali tu ces imati dosta manje freq na raspolaganju.
[ Milan Kragujevic @ 12.01.2020. 09:30 ] @
> Verovatno zato sto si stavio 20/40/80 XXXX

Na Tik wiki-ju je pisalo da uradim tako.

Uradio sam po tvojim instrukcijama.

https://milankragujevic.com/up...g.zwanoo.android.speedtest.jpg
[ bmarkovic06 @ 12.01.2020. 09:53 ] @
Skini wifi speedtest aplikaciju za android i skini server aplikaciju za windows. Pokrenes server aplikaciju a na androidu gadjas IP od racunara i tako mozes malo merodavnije da meris brzinu koju imas, pogotovu za upload. Potrudi se samo da ti je komp ovezan na 1gige interfejs.

https://play.google.com/store/...e.android.localwifispeedtester
[ Milan Kragujevic @ 12.01.2020. 10:04 ] @
Uradio sa 100 MB, https://milankragujevic.com/up...droid.localwifispeedtester.jpg

Upload: 166.23 Mbps
Download: 249.00 Mbps

Download je 57% od link speed, upload dosta nizak.

Interesuje me sada zašto mi običan speedtest.net na desktop-u ne radi ako sam preko MikroTik-a spojen, dok mi radi ako SBB modem uključim direktno u laptop? Modem radi u bridge modu i uređaju daje javnu IP adresu.

Na speedtest.net dobijem DOWNLOAD TEST ERROR. Podešavanja MikroTik-a vezana za Firewall nisam dirao, osim drop all incoming van 192.168.0.0/16 i allow incoming na portovima 80,443,8080,8443,1194,1723,32400. Sve to je forward-ovano na određenu IP adresu koja služi kao web servis i autorizacioni server gde se nalazi i VPN. 80 i 443 su forward-ovani samo ako je source IP drugačiji od 192.168.0.0/16, kako bi mi radio WebFig sa lokalne mreže.
[ Milan Kragujevic @ 12.01.2020. 10:19 ] @
Speedtest.net koristi port 5060 za svoje testiranje (a HTTP protokol), isključio sam sve što default dolazi vezano za SIP protokol, međutim još uvek imam problem.

Konekcija stoji u statusu "syn sent" ili "time wait", i onda bude timeout. Browser konzola prikazuje timeout za sve konekcije na port 5060.

https://milankragujevic.com/uploads/2020-01-12_111822.png
[ Milan Kragujevic @ 12.01.2020. 10:29 ] @
Restartovao sam MikroTik (nakon što sam uklonio sve vezano za port 5060), i radi speedtest.

https://www.speedtest.net/result/8937896492

Doduše opet sporije nego Cisco, gde je 295/15 Mbps, ali dobro.
[ Branimir Maksimovic @ 12.01.2020. 10:32 ] @
Glupo pitanje, da nije na mikrotiku ukljucen QoS?
[ Milan Kragujevic @ 12.01.2020. 10:41 ] @
Ako po default-u nije, onda nije. Ima svašta u queues, ali to nisam dirao, tako je default podešeno. "only-hardware-queue", "wireless-default" i "no-queue" za bridge interfejs.
[ Milan Kragujevic @ 13.01.2020. 00:09 ] @
Nije me sramota da priznam, glup sam ja za ovo. * Vratio sam običan ruter a MikroTik će na prodaju na KP. Nemam strpljenja ni vremena da učim sve ovo što on nudi, a nije mi u opisu posla niti bilo gde na karijernoj putanji mrežna administracija.

* Opet neki problemi sa TCP konekcijama koje ne "prolaze", ostaju otvorene satima, užasan protok, WiFi koji restartuje telefon, 2.4GHz WiFi na 2412 MHz na koji IP kamera ne može da se nakači, itd. Te probleme nemam sa običnim ruterom, a mrežno znanje mi je ograničeno na OpenWrt gde ono što nema u GUI-ju dopunjavam ručno sa iptables i dodatnim "polu-proprietary" interfejsima.
[ Branimir Maksimovic @ 13.01.2020. 01:12 ] @
Ako ti ne mozes da se snadjes ko moze da se snadje? Hm, kao da si zabo flakky hardware opet :p
[ Marcony @ 13.01.2020. 07:52 ] @
Citat:
npero:
Sto ne izaberes superchannel i no_country_set i na taj nacin iskljucis DFS ili ti detekciju radara ima neki ralzog secifican zasto ti treba aktivan DFS ?


Zbog ovoga...
http://ae5x.blogspot.com/2020/...rce-of-qrm-to-weather.html?m=1

[ Milan Kragujevic @ 13.01.2020. 09:22 ] @
@Marcony @npero Dok sam imao PTP link između Klenovnika i Kostolca, uvek sam poštovao svu zakonsku regulativu, i ako neki WISP provajderi nisu, iz prostog razloga što ne želim da pravim smetnje drugima kao što ne želim da drugi prave smetnje meni. A što se tiče DFS, kod nas MTT neće izvršavati zakon nad običnim kućnim ruterima, ali je svejedno nekorektno stvarati smetnje bilo kome.

Mada, u članku je navedeno da je 50mW smetnja, ovaj MikroTik odašilja 500 mW.
[ npero @ 13.01.2020. 09:49 ] @
Na mom hAP ac2 je snaga podesena na 15dB ili ti 30mW i namerno je namesten tako da cim izadjem iz stana 10m od vrata nema vise signala, da iskljucen je DFS ali moje misljenje je da ovako podeseno pravi mnogo manje smetnji nego da je na maksimalnoj snazi i ukljucen DFS.
Tako da po mom misljenju potpuno se uklapam u potrebe fer i racionalnog koriscenja slobodnog frekfenciskog opsega.
Mada ako nema ima vremena i nema pametnije sta da radi u zivotu i ima analizator spektra do 6GHz, nek navrati na pice pa malo da se promuvamo po kraju da vidimo sta ima :). Skup uredjaj niko nije bas voljan da pozajmljuje.
[ Milan Kragujevic @ 13.01.2020. 14:23 ] @
Moj WiFi 2.4G hvatam sa autobuske stanice, a 5G ispred prodavnice. Trebao bih stvarno da smanjim transmit power, imam jednosoban stančić, a wifi koristim na 3m od rutera, nego eto ostavio default 500mW, začudim se kad izađem iz voza i na pola puta ka kući uhvatim svoj WiFi.
[ Marcony @ 14.01.2020. 06:09 ] @
Smanji snagu, digni minimalnu brzinu i ogranicices na domet stana, sto je sasvim dovoljno za normalan rad.
[ bakara @ 14.01.2020. 12:11 ] @
Citat:
Milan Kragujevic:

Na speedtest.net dobijem DOWNLOAD TEST ERROR. Podešavanja MikroTik-a vezana za Firewall nisam dirao,

Ovo sam ja redovno dobijao sve dok nisam iskljucio ad bloker

Kada meris probaj sa njihovom aplikacijom.
https://www.speedtest.net/apps/windows
[ Branimir Maksimovic @ 14.01.2020. 15:47 ] @
Citat:
Milan Kragujevic:
Moj WiFi 2.4G hvatam sa autobuske stanice, a 5G ispred prodavnice. Trebao bih stvarno da smanjim transmit power, imam jednosoban stančić, a wifi koristim na 3m od rutera, nego eto ostavio default 500mW, začudim se kad izađem iz voza i na pola puta ka kući uhvatim svoj WiFi.


Otkud toliko jaka snaga po defaultu? Obicno je 16dbm za Srbiju.
[ Milan Kragujevic @ 14.01.2020. 18:33 ] @
U međuvremenu je podešeno no_country_set i superchannel.
[ Marcony @ 14.01.2020. 19:39 ] @
Citat:
npero:
Mada ako nema ima vremena i nema pametnije sta da radi u zivotu i ima analizator spektra do 6GHz, nek navrati na pice pa malo da se promuvamo po kraju da vidimo sta ima :). Skup uredjaj niko nije bas voljan da pozajmljuje.


Mozes i sam da probas...
http://timnetworks.rs/wpe/2019...-radars-how-often-does-it-hit/
[ npero @ 15.01.2020. 06:49 ] @
Da samo sto mene interesuje ceo spektar ne samo konkretni dfs signal, ovo pomaze ali ne radi posao koji sam zamislio, a pored svega nema ni pica ni jela samo kucanje po tastaturi nije zanimljivo uopste :):).
[ Milan Kragujevic @ 15.01.2020. 09:48 ] @
Snašao sam se, Hardware Offload je bio isključen na eth0 (tj. LAN1/WAN/PoE In) i naravno Internet je radio loše a CPU usage bio visok.

WiFi sam nekako podesio, ne znam ni kako niti želim da znam. Smanjio TX Power na 13 dBm na 2.4GHz i 17 dBm na 5 GHz (bio je 28 dBm na oba).
[ Milan Kragujevic @ 20.01.2020. 21:55 ] @
Skinuo MikroTik opet. Štetno utiče na EPC3208, net se redovno prekida i Cisco zakucava kad je MikroTik prikačen, kad stavim kršinu AC12G sve radi lepo.
[ Milan Kragujevic @ 25.01.2020. 13:23 ] @
Zamenili su mi EPC3208 sa CGA2121. Isti problem, kad stavim MikroTik na CGA imam svakakve probleme, prekide, suludi ping, pad brzine, nestanak neta, CGA se restartuje, itd. Kad skinem MikroTik i stavim kršinu AC12G radi odlično, kao i kada sam spojen direktno na CGA. Testirao dva dana bez problema, a sa MikroTik-om se problemi pojave posle sat vremena. Ako skinem Tik i spojim računar u CGA odmah proradi, bez potrebe da se CGA restartuje.

Da li realno hAP ac2 ne može da progura 300 Mbps, ili ja ne znam da ga podesim?!
[ Branimir Maksimovic @ 25.01.2020. 16:57 ] @
To je problem sa konekcijama, pogotovo sto se CGA restartuje. Ne verujem sad da je taj mikrotik defektan ili nesto slicno. Ocigledno da imas problema sa nekim uredjajem i da mikrotik
dize konekcije. Mozda na miktoriku da smasnjis time_wait trajanje konekcije, tj da ih brze otkacinje kako se ne bi gomilale. Ima to lako podesiti na dd-wrt, za mikrotik ne znam.
[ Milan Kragujevic @ 08.04.2020. 12:00 ] @
Evo opet problemi, iste prirode.

Svako jutro moram da restartuje mikrotik jer mi se zakuca. Bio sam ga update-ovao na routeros sa install i resetovao sve. I bilo je ok danima na default konfiguraciji. Onda sam dodao 20+ static IP pravila, VPN client, neke rute, dva WAN-a, povećao broj klijenata, i počelo je. Nije do prebrzog neta jer nije brži od 200 Mbps (4G). Ne pregreva se nešto posebno.

Jednostavno, ustanem ujutru, sednem za PC i neta polu-ima, tj. sve užasno loše radi, ping >1000ms, i ako je ka intranetu, tj. ka drugim uređajima. Ping ka tik-u je jutros bio <1ms, ali ka drugom računaru pored je bio užas, kao i ka modemima, uređajima u drugoj kući, itd. Nema veze koliko je uređaj fizički daleko (npr. isto sporo radi i ka računaru koji je na drugom port-u i pored mog kao i ka IP kameri udaljenoj 100m u zadnjem dvorištu između koje ima ne znam ni sam koliko svičeva i raspalih kablova). Isključivanjem svih kablova iz Tik-a osim 2 (PC i PC ili PC i modem) ne rešava se problem, samo restartom.

CPU bude 0-1%, RAM 50%... Kako da dijagnostikujem problem? Do sada nisam koristio Tik pa nisam se žalio dva meseca, sad opet isto. Dakle hardver je OK, ali nešto što mu ja radim ne valja. Ovaj put firewall nisam dirao.
[ Milan Kragujevic @ 09.04.2020. 07:57 ] @
Još jedno jutro, još jedan zakucan 'tik. Ubacio sam u scheduler da pokrene /system reboot u 05:30 svaki dan. Za sada...
[ Milan Kragujevic @ 10.04.2020. 07:12 ] @
Jutros radi, nije se zakucao :) U log-u stoji router rebooted po tajmeru!
[ calexx @ 10.04.2020. 08:05 ] @
Citat:
Milan Kragujevic:Još jedno jutro, još jedan zakucan 'tik. Ubacio sam u scheduler da pokrene /system reboot u 05:30 svaki dan. Za sada...
Ti se baš družiš sa tim problemima, em problemi sa provajderima em problemi sa uređajima ... kod tebe ni Moskvič ne bi dobro radio. ;) Ja 90% koristim ono što mi provajder daje, sada je tu Netis WF2780 i sve radi u svakom trenutku. Ali ne testiram izdržljivost, samo koristim. Nemam iskustva sa prevelikim brzinama i prevelikim trošenjem.
[ Milan Kragujevic @ 10.04.2020. 08:21 ] @
Ti imaš prevelike brzine, meni se crash-uje i na 20 Mb/s DSL.

Na poslu imaju teoriju da ja zračim neku negativnu energiju koja uništava računare, čim se približim sve pocrka. Kad se moj telefon nakači na Aruba/Meraki/Ubiquiti štaveć AP-ove po firmi odma explodira neki server.

Enivej, i meni radi od provajdera sva oprema. Meni radi i Mikrotik na default podešavanjima, ali niko ne kupuje Mikrotik zbog WiFi i DHCP i NAT. Evo Telekomovi xDSL modemi mi ne crkavaju, jedini koji je imao problem je bio H368N 2016. godine, nije radio VDSL na njemu dobro, kad stavili drugi onda radilo. Sve ostalo menjali sami jer im je default da ako ne radi npr. IPTV oni zamene modem. Drugo, netis uređaji su po meni najbolji ruteri, imam PHP klasu za interfejsing sa web API-jem netis rutera (svi imaju isti), 1000x bolje nego TP-Link. A imam i neki Mercusys koji može čak gigabit Internet da podrži bez problema, dok na Tik-u počne raspad.

Ali, kad bi vi svi videli šta je moja "kućna" mreža na više lokacija (BG, selo, rođaci su isto prikačeni zbog televizije u intranetu), i koliko routing rules ja imam ka (i od) svim tim stvarima, nekome ne bi bilo dobro odavde.

Zašto? Cuz it's fun, i jeftinije. I 100% uptime uplink-a :) I adblocking DNS, monitoring i remote support za članove porodice.
[ calexx @ 10.04.2020. 09:00 ] @
Citat:
Milan Kragujevic: Ali, kad bi vi svi videli šta je moja "kućna" mreža na više lokacija (BG, selo, rođaci su isto prikačeni zbog televizije u intranetu), i koliko routing rules ja imam ka (i od) svim tim stvarima, nekome ne bi bilo dobro odavde.

Zašto? Cuz it's fun, i jeftinije. I 100% uptime uplink-a :) I adblocking DNS, monitoring i remote support za članove porodice.
To sam i hteo da kažem, ja ne testiram izdržljivost i dokle se može nego samo koristim. A takvih je veliki broj, zato kod tebe i brlja, a mora da brlja pod takvim uslovima.

Mada .... možda ima i ovoga. ;)
Citat:
Milan Kragujevic: Na poslu imaju teoriju da ja zračim neku negativnu energiju koja uništava računare, čim se približim sve pocrka. Kad se moj telefon nakači na Aruba/Meraki/Ubiquiti štaveć AP-ove po firmi odma explodira neki server.
Za mene važi druga priča, kad god me neko pozove da mu sredim problem, problem nestane kad sednem za komp. Čak i kad uradim nešto što sam pre toga predložio telefonom i nije bilo uspešno, mada je tu obično neki detalj koji su oni prevideli. ;)
[ bmarkovic06 @ 10.04.2020. 09:36 ] @
Citat:
Milan Kragujevic:
Evo opet problemi, iste prirode.

Svako jutro moram da restartuje mikrotik jer mi se zakuca. Bio sam ga update-ovao na routeros sa install i resetovao sve. I bilo je ok danima na default konfiguraciji. Onda sam dodao 20+ static IP pravila, VPN client, neke rute, dva WAN-a, povećao broj klijenata, i počelo je. Nije do prebrzog neta jer nije brži od 200 Mbps (4G). Ne pregreva se nešto posebno.

Jednostavno, ustanem ujutru, sednem za PC i neta polu-ima, tj. sve užasno loše radi, ping >1000ms, i ako je ka intranetu, tj. ka drugim uređajima. Ping ka tik-u je jutros bio <1ms, ali ka drugom računaru pored je bio užas, kao i ka modemima, uređajima u drugoj kući, itd. Nema veze koliko je uređaj fizički daleko (npr. isto sporo radi i ka računaru koji je na drugom port-u i pored mog kao i ka IP kameri udaljenoj 100m u zadnjem dvorištu između koje ima ne znam ni sam koliko svičeva i raspalih kablova). Isključivanjem svih kablova iz Tik-a osim 2 (PC i PC ili PC i modem) ne rešava se problem, samo restartom.

CPU bude 0-1%, RAM 50%... Kako da dijagnostikujem problem? Do sada nisam koristio Tik pa nisam se žalio dva meseca, sad opet isto. Dakle hardver je OK, ali nešto što mu ja radim ne valja. Ovaj put firewall nisam dirao.



Problem moze da bude do tih sviceva sto imas dalje. Raskaci ti lepo sve te sviceve, restartuj tik i vidi hoce li zabadati. Probaj da mu pridjes i na bridge interfejsu ugasis stp, jer mozda imas negde loop na mrezi na sta mi i smrdi ceo problem.

Mikrotik ima veliku pouzdanost. Imam ih na mrezi 1000+ komada i nikada nijedan slican problem, osim naravno kada se dogodi loop.

Ako ni posle svega ovoga on ne proradi, ti ga reklamiraj, nesto nije uredu sa njim. Ne znam sta drugo da ti kazem.
[ Milan Kragujevic @ 10.04.2020. 09:43 ] @
Ne mogu ovog trenutka da raskačim svičeve jer mi trebaju danas, ali ću ugasiti STP i disable-ovaću auto reboot pa se javljam sutra ujutru. Ako se zakuca onda ću sutra sve otkačiti osim svog računara a ostali config ostaviću isto, pa ćemo videti.

edit: Pitanje - ruter je kupljen preko Alti doo, tj. WINWIN Retail doo, koji je trenutno u blokadi. Nije preko Netiksa uveženo, zato me brine da li ću moći da servisiram ruter koji je kupljen kod i uvežen od strane firme koja više ne posluje. WinWin radnje su inače prodaje Tehnomaniji, koja je sada vlasnik radnji direktno, a WINWIN Retail je ugašen.
[ calexx @ 10.04.2020. 10:10 ] @
Koliko znam, Tehnomanija prihvata sve nasleđeno od firmi koje je preuzela. Uvoznik je WW?
[ Milan Kragujevic @ 10.04.2020. 10:16 ] @
Da, to je cudno meni. Koliko znam Netiks i Sampro uvoze Tikove.

Odnecu im posle korone neka testiraju, sve ovo je mnogo cudno. Imam i stampac koji sam uzeo pred koronu i preskace svaku drugu liniju kad stampa, moram i to da reklamiram.
[ Milan Kragujevic @ 11.04.2020. 13:35 ] @
Nije se zakucao danas, mada nije mi jutro sada. Šta sam uradio: Ugasio STP na bridge-u. Imam inače IPTV uređaj koji možda koristi multicast, pa to možda pravi packet storms, jer ja to ne znam da podesim kako treba, pa sam i to skinuo sa mreže.
[ Milan Kragujevic @ 15.04.2020. 08:00 ] @
Definitivno do STP (tj. do lošeg dizajna mreže po principu "krpi i svičuj"), juče sam rekreirao bridge i zaboravio da stavim STP na none. Opet se zakucao jutros, osim što sam ovaj put ušao u WinBox i samo isključio STP (što je restartovalo bridge interfejs) i sada radi normalno, a nije restartovan ruter, tj. ceo OS.
[ rkramer @ 24.04.2020. 19:48 ] @
Pogledaj https://forum.mikrotik.com/viewtopic.php?f=2&t=153988#p774179

Izgleda da postoji puno prijavljenih problema sa hAP ac2 (restartovanje, zaglavljivanje) koji vode ka NTP paketu.
Ne kažem da nije do STP-a, ali nije loše staviti u perspektivu.

[ Milan Kragujevic @ 25.04.2020. 01:00 ] @
Ma nije do STP-a ja sam prebrzo doneo zaključak, u periodu od 4 dana se zakucao samo priključen na WAN port bez povezanih klijenata bilo koje vrste. Sad sam ga stavio nepovezanog da vidim da li će raditi posle par dana.

Koliko vidim hAP ac2 je najlošiji (u vezi sa stabilnošću rada) Mikrotik uređaj u poslednjih par godina. Ne vidim zašto bi to bilo tako, imali su jeftine uređaje pre, imali su i Qualcomm arm uređaje pre, ne znam.

Mnogi korisnici imaju raznorazne probleme sa hAP ac2, i tu ne vidim neki prostor za rešavanje bez ispravke problema od strane vendor-a, što bi zahtevalo da prvo "priznaju" problem, ali na forumima samo ubeđuju korisnike
da su korisnici boranija i da ne znaju da koriste ruter. A ruter izgleda ne može (određenom broju korisnika) da radi ni najosnovnije funkcije koje obavlja Netis za 1200 din sa 16 MB RAM i 2 MB SPI Flash.
[ bmarkovic06 @ 25.04.2020. 07:53 ] @
Citat:
Milan Kragujevic

Mnogi korisnici imaju raznorazne probleme sa hAP ac2, i tu ne vidim neki prostor za rešavanje bez ispravke problema od strane vendor-a, što bi zahtevalo da prvo "priznaju" problem, ali na forumima samo ubeđuju korisnike
da su korisnici boranija i da ne znaju da koriste ruter. A ruter izgleda ne može (određenom broju korisnika) da radi ni najosnovnije funkcije koje obavlja Netis za 1200 din sa 16 MB RAM i 2 MB SPI Flash.


Ne znam sta da ti kazem. Uzmi lepo Netis i resi se muke sa mikrotikom.

Vec sam jednom naveo da na sopstvenoj mrezi imam preko 1000 uredjaja raznoraznih modela i to radi izuzetno stabilno. Cak i dosta stabilnije nego sto sam ocekivao od boardova tog cenovnog ranga.

Cak sam i nekoliko mini hidro elektrana povezao najjeftinijim hap lite mikrotikovima i nikada nijedan problem niti jedno jedino zaglavljivanje u toku od 3-4 godine.

Na jednom kamenolomu sam imao priliku videti kako su dva puta menjali Moxa industrijski switch od ~1000eur, crkavao napolju a u istoj kutiji vec 10 godina stoji rb450 i radi bez ijedne greske godinama.
[ Milan Kragujevic @ 25.04.2020. 08:11 ] @
Nisi razumeo šta sam rekao, očigledno, čim spominješ hAP lite i RB450. A nisi razumeo ni nameru iza mojih navoda.

hAP ac2 je problematičan model, ovo što sam rekao ne važi za sve Mikrotik uređaje, svakako.

Ne možeš da generalizuješ i da tvrdiš da hAP ac2 radi uvek i da "uzmem lepo netis i rešim se muke sa mikrotikom" zato što svi ostali hAP i hex modeli i štaveć imaju rade kako treba.

Prvo, većina nisu arm nego mips, drugo, Mikrotikls je sasvim sposoban da upropasti samo jedan model ili deo proizvedenih uređaja nekog modela, a da ostale uređaje na istom SoC implementira "kako treba".

Osim toga, nemoj se osećati lično povređenim jer mi ne radi hAP ac2 (doduše ne samo meni, očigledno više od pola korisnika koji imaju hAP ac2 imaju bar jedan koji se zakucava i restartuje redovno), ništa to ne mora da govori za Mikrotik kao kompaniju (doduše druge stvari govore mnogo više nego što bi neispravni hAP ac2 uređaji mogli rekli), niti to može da ospori da tebi svi Mikrotik uređaji rade. Pa čak i da imaš 100 hAP ac2 i da ti rade super to ne znači da će nekome drugom neki hAP ac2 da radi dobro, a ja ne ekstrapolišem da su svi uređaji neispravni jer moj jedan ne radi, već samo čitam iskustva drugih korisnika sa ovim modelom.

Ovo nije poziv na dokazivanje čiji je ruter superiorniji, ali je činjenica da bi ruter od 100€ sa quad core ARM SoC na 716 MHz, 128 MB RAM i 16 MB Flash trebao da radi makar dovoljno dobro kao ruter od 10€ sa 400 MHz single core lexra/mips procesorom, 16 MB RAM i 2 MB Flash. A ovaj hAP ac2 radi lošije nego hAP mini koji spominješ, samom činjenicom da se zakuca kad nema povezanih uređaja.
[ bmarkovic06 @ 25.04.2020. 08:19 ] @
Citat:
Milan Kragujevic: Nisi razumeo šta sam rekao, očigledno, čim spominješ hAP lite i RB450. A nisi razumeo ni nameru iza mojih navoda.

hAP ac2 je problematičan model, ovo što sam rekao ne važi za sve Mikrotik uređaje, svakako.

Ne možeš da generalizuješ i da tvrdiš da hAP ac2 radi uvek i da "uzmem lepo netis i rešim se muke sa mikrotikom" zato što svi ostali hAP i hex modeli i štaveć imaju rade kako treba.

Prvo, većina nisu arm nego mips, drugo, Mikrotikls je sasvim sposoban da upropasti samo jedan model ili deo proizvedenih uređaja nekog modela, a da ostale uređaje na istom SoC implementira "kako treba".

Osim toga, nemoj se osećati lično povređenim jer mi ne radi hAP ac2 (doduše ne samo meni, očigledno više od pola korisnika koji imaju hAP ac2 imaju bar jedan koji se zakucava i restartuje redovno), ništa to ne mora da govori za Mikrotik kao kompaniju (doduše druge stvari govore mnogo više nego što bi neispravni hAP ac2 uređaji mogli rekli), niti to može da ospori da tebi svi Mikrotik uređaji rade. Pa čak i da imaš 100 hAP ac2 i da ti rade super to ne znači da će nekome drugom neki hAP ac2 da radi dobro, a ja ne ekstrapolišem da su svi uređaji neispravni jer moj jedan ne radi, već samo čitam iskustva drugih korisnika sa ovim modelom.

Ovo nije poziv na dokazivanje čiji je ruter superiorniji, ali je činjenica da bi ruter od 100€ sa quad core ARM SoC na 716 MHz, 128 MB RAM i 16 MB Flash trebao da radi makar dovoljno dobro kao ruter od 10€ sa 400 MHz single core lexra/mips procesorom, 16 MB RAM i 2 MB Flash. A ovaj hAP ac2 radi lošije nego hAP mini koji spominješ, samom činjenicom da se zakuca kad nema povezanih uređaja.


Ja sam ti vec pisao da uredjaj reklamiras ako je tako kako navodis.
[ Milan Kragujevic @ 25.04.2020. 08:23 ] @
Naravno, čim prođe lockdown, uređaj ću poslati na reklamaciju, ako Tehnomanija WinWin bude hteo da ga prihvati na servis (moraće, preuzeli su sve obaveze WINWIN Retail doo i WINWIN Shop doo). U međuvremenu sam ga ostavio uključenog bez kablova i sa ugašenim WiFi, a posle par dana ću probati da vratim mrežu i konfiguraciju ali da isključim/obrišem NTP jer je to pisalo na linku koji je poslao @rkramer.
[ Branimir Maksimovic @ 25.04.2020. 08:24 ] @
A da probas sa nekim drugim FW? Mislim da je ovo cisto softverski problem, nekako imam taj osecaj...
[ Milan Kragujevic @ 25.04.2020. 08:31 ] @
Kad završim testiranje bez kablova, mogu da uradim reinstall sa netinstall i da stavim oldstable verziju RouterOS, obrišem NTP i ugasim STP, downclock-ujem SoC i ugasim IPSec podršku. Polako, mora temeljno da se testira, traje to neko vreme...

edit: I ja mislim da je softverski problem, jer se u nekim situacijama zakucavanja samo ugasi Winbox i web interfejs pristup, ping ka ruteru ne radi, ali ping ka Internetu radi (doduše veoma otežano) i ne radi DNS. Da se CPU srušio ne bi ni Ethernet portovi radili.
[ rkramer @ 25.04.2020. 12:52 ] @
Citat:
bmarkovic06: Ne znam sta da ti kazem. Uzmi lepo Netis i resi se muke sa mikrotikom.

Vec sam jednom naveo da na sopstvenoj mrezi imam preko 1000 uredjaja raznoraznih modela i to radi izuzetno stabilno. Cak i dosta stabilnije nego sto sam ocekivao od boardova tog cenovnog ranga.


Imam utisak da ovo jako zavisi od individualnog use case-a
Nisam previše radio sa Mikrotik uredjajima, ali sam uvek pomalo pratio (držao na radaru).

Skoro sam imao zahtev za nekoliko uredjaja za klasičnu road-warrior upotrebu, i odlučio se za Mikrotik zbog najbolje konfigurabilnosti.

Broj prepreka na koje sam naišao prilikom konfiguracije je bio, za moj ukus, zapanjujuć. Međutim, priznajem da je i broj podržanih (u manje ili više zreloj fazi) tehnologija zapanjujuć.

Moj zaključak iz ovog projekta je da:

- Mikrotik najbolje radi sa Mikrotikom sa druge strane (nije moj slučaj)
- RouterOs je u stalnim (velikim) promenama, i treba ga pratiti. U verziji 7 se markiranje rutiranih paketa radi drugačije. ROS 6.41 uvodi promene u konfigurisanju switch portova (master-slave -> bridge)
- Naizgled velike mogućnosti konfiguracije se svode na poznavanje mnogih 'poznatih' ograničenja. Jedan od primera je OpenVpn podrška koja postoji, ali ne i za Udp, niti za kompresiju. Udp podrška je posle x godina uvedena u Ros 7. Koji je u beti. Udp OpenVpn zapravo lepo radi u toj beti. Ali ta beta zapravo ima problema sa rutiranjem.

Naleteo sam na još par ograničenja u drugim segmentima, ne sećam se više svih.

Po mom iskustvu Mikrotik jako upotrebljiv uredjaj, ali je potrebno pravim slalomom izbeći prepreke, problematične module i verzije softvera, polu-podržane feature, kao i nekompatibilnosti izmedju uredjaja zbog različite verzije softvera.

Ako uspete inicijalno da konfigurišete uredjaj da vam obavlja posao koji vam je potreban, i na način koji je potreban, verujem da ćete biti zadovoljni sa njim, i narednih 10 ili 100 neće biti preveliki problem.

Mislim da je upravo u ovome trik: ukoliko u projekat ulazite sa niskim budžetom i puuno entuzijazma, verovatno ćete uspeti da završite posao sa Mikrotik opremom.

Ukoliko ulazite sa zakucanim planom i specifikacijama koje moraju da se ispoštuju, a nisu uzimale Mikrotik konkretno u obzir, možete biti i razočarani.
[ Milan Kragujevic @ 25.04.2020. 16:55 ] @
Zakucao se, i ne može ni reset. Otvori Winbox na sekundu i prestane da odgovara na bilo šta, ne reaguje uošte, a internet propušta (poneki ping prođe, jako sporo ali zatraži DHCP IP adresu na wan interfejsu, itd.). Međutim, reset dugmetom ne radi, uvek se bootuje sa starim SSID-om.

U ponedeljak idem u WinWin i šaljem im na reklamaciju, ovo je neispravan uređaj definitivno i neću više vremena da trošim na njega. Jasno kao dan da je neispravan, nijedan Mikrotik se ovako ne ponaša (doduše samo WISP antene sam imao).

edit: I da, lepo sam resetovao, tj. sam se rebootuje posle 30s držanja dugmeta, nisam glup. Ali ne obriše konfiguraciju. Dakle neispravan hardver.
[ Branimir Maksimovic @ 25.04.2020. 17:12 ] @
"Ali ne obriše konfiguraciju. Dakle neispravan hardver. "

Lici da se skucao, flash... tako sam ja spalio jedan ruter nakon jedno 30
flashovanja openwrt-a. I dobio novi. Definitivno ne bi trebalo da ode posle
samo toliko. Doduse sprzio sam i jedan novcijat usb flash na istom ruteru nakon
par dana :P
[ Milan Kragujevic @ 30.04.2020. 11:09 ] @
Posle mirovanja bez povezanog kabla i sa ugašenim WiFi-jem sam spojio dva računara i pingovao:



Znači default config, sa ugašenim WiFi, bez kablova spojenih, nije se pregrevao.
[ bmarkovic06 @ 02.05.2020. 18:33 ] @
Otkad je 172.16.0.0/24 deff config?
[ Milan Kragujevic @ 03.05.2020. 09:15 ] @
Nije. Podešen je kroz Quick Setup interfejs.

Pošto ga Tehnomanija nije htela nazad ("nije kupljen kod nas nego online u WinWin mi smo samo radnje kupili"), hoćeš li da ti pošaljem ruter pa ga testiraj i napiši analizu? Mislim, čisto da vidimo da li lažem ili spejšip ruter od 100€ stvarno ne može da se ne sruši za ~dva dana uptime...
[ Branimir Maksimovic @ 03.05.2020. 09:24 ] @
"spejšip ruter od 100€"

Tesko da ces za te pare imati spejsip ruter :P
Gledaj ovo: https://www.tp-link.com/en/hom...king/wifi-router/archer-c4000/
Kod nas jos ne moze da se nadje :P
[ Milan Kragujevic @ 03.05.2020. 09:40 ] @
Šta će mi to, meni telefon ima jednu antenu na 5GHz, dakle 1x1 do 433 Mb/s, to može i najjeftiniji dual band ruter. Ti spejšipi bi imali smisla da mi je cela mreža bežična i da želim da imam gigabit agregatno, što nije primenjivo u mom slučaju, sve je kablirano, samo telefon je na WiFi-ju, i tu mi je najbitnije da je ping dovoljno nizak da radi browsing i YouTube, a brzina ~20 Mb/s je dovoljna, može i manje ali da je stabilno da izbaferuje video
[ Branimir Maksimovic @ 03.05.2020. 10:40 ] @
Ma ja ne gledam to nego kolko ima korova i kolko ram-a, da mogu da se igram :P
[ Milan Kragujevic @ 03.05.2020. 11:14 ] @
Gomila tih spejšip TP-Link-ova imaju zaključan bootloader. Igraćeš se isto kao i na single core 400 MHz ath9k MIPS sa 32MB RAM.
[ Branimir Maksimovic @ 03.05.2020. 12:02 ] @
Bah sad vidim, nista od entware-a. Zato su ovi Asus-ovi odlicni cak i sa stock firmware-om. Gledam ovaj AX58U, ali jos
nemam ni jedan uredjaj sa Wifi6 ;)
[ djricky @ 06.05.2020. 17:04 ] @
bas me interesuje sta se desilo s tim tvojim ruterom
ja sa hAP AC vec godinu i kusur nikad nikakav problem...
[ bmarkovic06 @ 06.05.2020. 17:29 ] @
Citat:
djricky: bas me interesuje sta se desilo s tim tvojim ruterom :)
ja sa hAP AC vec godinu i kusur nikad nikakav problem...


Mene isto :)


Ako hoce neka mi ga posalje na test od mesec dana pa da vidim kako se ponasa.
[ Milan Kragujevic @ 06.05.2020. 17:30 ] @
Jel hAP ac2 ili hAP ac? To su dva potpuno različita uređaja. Jedan je MIPS Atheros ("Qualcomm"), drugi je ARM Qualcomm. To što se zovu hAP ac i ac2 pa deluju slično ne znači apsolutno ništa.
[ Milan Kragujevic @ 06.05.2020. 17:42 ] @
Naravno da hoću kao što sam napisao, poslao sam ti PP. Meni uređaj ne znači ništa, i stojim iza svojih tvrdnji.
[ djricky @ 06.05.2020. 17:50 ] @
pardon, moja greska, ja imam hAP AC.
[ bmarkovic06 @ 06.05.2020. 17:53 ] @
Evo odg sam ti na PP. Ima par clanova ovde koji me licno poznaju, cisto da ne mislis da cu te preci, da mi posaljes uredjaj i da te zavrnem pa ne vratim.
[ Milan Kragujevic @ 06.05.2020. 18:09 ] @
Odgovorio sam na PP. Znam te, i za WISP i sa FB iz nekih grupa. Zbog toga i šaljem, ne možeš se sakriti